Yet another ATI problem

I’m trying to use the ATI card in my laptop without success and It’s getting very frustrating. I’m new to openSUSE but not new to linux. Starting with 11.4 vanilla install then upgrades from packman.

I have a dual Intel/ATI card on an HP touchsmart tm2:

--> /sbin/lspci -vnn |grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M93 [Mobility Radeon HD 4500 Series] [1002:9555] (prog-if 00 [VGA controller]

The laptop won’t boot unless the radeon driver is disabled with radeon.modeset=0. I now have “blacklist radeon” in /etc/modprobe.d/99-local.conf so it will boot with the intel driver.

First of all, there doesn’t seem to be a module for vga_switcheroo for my kernel, is this true? Do I need to grab a later kernel from elsewhere? I have the following:

--> uname -a
Linux #1 SMP PREEMPT 2011-07-21 02:17:24 +0200 x86_64 x86_64 x86_64 GNU/Linux

which should support vga_switcheroo module.

Booting to runlevel 3 and doing “modprobe -v radeon modeset=1” loads the driver OK. I then modified /etc/X11/xorg.conf.d/50-device.conf to:

Section "Device"
  Identifier "Default Device"

  Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"
  Option "monitor-LVDS" "Default Monitor"


and switched to runlevel 5, but X dies with “(EE) No devices detected.”

dmesg reports

 2015.458973] [drm] Radeon Display Connectors
 2015.458976] [drm] Connector 0:
 2015.458978] [drm]   LVDS
 2015.458982] [drm]   DDC: 0x7f68 0x7f68 0x7f6c 0x7f6c 0x7f70 0x7f70 0x7f74 0x7f74
 2015.458985] [drm]   Encoders:
 2015.458987] [drm]     LCD1: INTERNAL_UNIPHY2
 2015.458989] [drm] Connector 1:
 2015.458991] [drm]   VGA
 2015.458995] [drm]   DDC: 0x7fa0 0x7fa0 0x7fa4 0x7fa4 0x7fa8 0x7fa8 0x7fac 0x7fac
 2015.458997] [drm]   Encoders:
 2015.459131] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
 2015.459134] [drm] Connector 2:
 2015.459136] [drm]   HDMI-A
 2015.459138] [drm]   HPD1
 2015.459141] [drm]   DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
 2015.459144] [drm]   Encoders:
 2015.459146] [drm]     DFP1: INTERNAL_UNIPHY

so I think the monitor id should be “monitor-LVDS” for the laptop LCD. Am I missing something?

I also tried the ATI fglrx driver (v 11.9 from their website). This ends up dying with “Incorrect graphics BIOS signature”. Grrr. Although dual cards are not supported, I was hoping that the driver would just ignore the intel side, since the Mobility Radeon HD 4500 is supported. No go. The HP tm2 doesn’t have a BIOS option to switch to only one card so I think that pretty much screws getting the proprietary driver working unless there is a way to bypass the signature test?

Any help would be much appreciated! I’m at a loss with this.

The HP tm2 doesn’t have a BIOS option to switch to only one card so I think that pretty much screws getting the proprietary driver working unless there is a way to bypass the signature test?

I don’t like your chances here. I think the only way to get progress on this may be to file a bug report

Unofficial AMD Linux Bugzilla Main Page

and see what help you can get via

Main Page -

Hi deano, not much point in filing a bug report as they explicitly say they do not support combined cards. I was just hoping that their driver would still work with just the ATI card.

As to radeon driver - it’s weird, now vga_switcheroo is showing up. I’m sure it wasn’t before, and I haven’t changed anything. Bizzare.

Anyway, I can switch it off etc by echoing commands to /sys/kernel/debug/vgaswitcheroo/switch but when I tried to switch to using the radeon driver by:

echo DDIS > /sys/kernel/debug/vgaswitcheroo/switch
restart X

My laptop hung with a black screen. Looking at the logs it seems X picked up both radeonhd and radeon. Might try disabling radeonhd…

Nope. Still hangs without the radeonhd (well screen blank and no response to keyboard, but it did shutdown nicely with the power button)

Last things X said was:

  5060.872] (II) RADEON: Driver for ATI Radeon chipsets:
        ATI Radeon Mobility X600 (M24) 3150 (PCIE), ATI FireMV 2400 (PCI),
        ATI Radeon Mobility X300 (M24) 3152 (PCIE), 
        ... blah blah blah ...
  5060.877] (II) FBDEV: driver for framebuffer: fbdev
  5060.877] (II) VESA: driver for VESA chipsets: vesa
  5060.877] (++) using VT number 8

  5060.883] (II) [KMS] Kernel modesetting enabled.
  5060.884] (WW) Falling back to old probe method for fbdev
  5060.884] (II) Loading sub module "fbdevhw"
  5060.884] (II) LoadModule: "fbdevhw"
  5060.884] (II) Loading /usr/lib64/xorg/modules/
  5060.884] (II) Module fbdevhw: vendor="X.Org Foundation"
  5060.884]    compiled for 1.9.3, module version = 0.0.2
  5060.884]    ABI class: X.Org Video Driver, version 8.0
  5060.884] (WW) Falling back to old probe method for vesa
  5060.884] (**) RADEON(0): Depth 24, (--) framebuffer bpp 32
  5060.884] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
  5060.884] (==) RADEON(0): Default visual is TrueColor
  5060.884] (==) RADEON(0): RGB weight 888
  5060.884] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
  5060.884] (--) RADEON(0): Chipset: "ATI Mobility Radeon 4500 Series" (ChipID = 0x9555)
  5060.885] (II) RADEON(0): PCIE card detected
  5060.885] drmOpenDevice: node name is /dev/dri/card0
  5060.885] drmOpenDevice: open result is 10, (OK)

Anyone have any ideas?