Yesrterday's Kernel Upgrade Screws Up Graphics


I’m used to kernel updates screwing up both my graphics drivers and my instaltion of parallels. These things break each and every time the kernel is updated. Normally, reinstalling makes the problem go away and I move on. Yesterday, Parallels got screwed and I fixed it by reinstalling but the graphic driver is yet to work.

For reference I am using OpenSUSE 11.2 64-Bit Gnome-Edition with an ATI Radeon 4650, since it probably makes a difference.

For some reason the driver from the repo (ATI’s repo) would not install and I got errors saying that it has a wrong signature and (ignoring that) I got another error saying it was corrupted. So I could not install as usual.

Instead I went at ATI’s site and downloaded the latest driver. It installed but I lost the mouse cursor so I reinstalled the previous version which also installed but it not working properly, although I do have a mouse cursor.

glxinfo gives the following error:
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 136 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 24
Current serial number in output stream: 24

fglrxinfo outputs the exact same thing.

OpenGL is not working in any way. Even the gears demo and desktop effects (which I tried to reactivate just to test, since I hate those things) simply do not work.

Any ideas how to fix this? More information needed?

Thanks in advance,

  • Itai

How did you install the radeon driver - from the ati repo or using the ati driver?
If you used the repo, it should update the kernel driver module automatically.
If not, you have to reinstall the ati driver after each kernel uppgrade.

Well, the one from the repo did not work, so yes I had to reinstall it. Unfortunately, that did not work either and I lost the mouse pointer, I reinstalled an older one from ATI which gave me the mouse pointer back but it does not work for 3D/OpenGL, it gives me the error in my previous post. So I’m guessing the instalation partly failed somewhere even for that one (that was the one that worked before the update) but there was no error or anything.

How do I fix the broken driver or install the one from the repo, which would hopefully work? The repo one refuses to install, it first says the signature is wrong and if I ignore that error it says it is corrupted.

Thanks in advance,

Before you install the repo driver, you need to delete the ati one you manually installed.
The thing is, it should update the repo driver automatically when you upgrade the kernel.
I can’t check on 11.2 because my system with ati is running SLED 11 and the kernel is not the same version as the opensuse one.

Have a look at this:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums
and also the first thread in the 64 bit hardware where someone else is also having a problem.

If you can’t get it going, roll back to the previous kernel and wait a week or so till the repos catch up.

OK, now that I read those documents, I am even more confused or perhaps my system is confused. According to the link there are several ATI drivers which can be used in place of each other.

However, my system now (not sure if this was the case when it was working) has both a fglrx (x11-video-fglrxG02 8.661-25.1 x86_64 from the ATI repo which fails upgrading to 8.681-28.1) and a radeonhd (xorg-x11-driver-video-radeonhd 1.3.0_20100216_79a0ab2-0.1.1 x86_64 from the OpenSUSE 11.2 updates repository).

The latest driver I installed was from ATI’s download site (not the repo) and was a .run file (not a .rpm), so I may have three versions installed. Unfortunately, this one installs itself when run and there does not seem to be a way to have it uninstall itself.

I have no idea what to do now… Should I uninstall something? Is there a way to reset the graphics driver without uninstalling (because it may not be possible or work)? It would be nice to be able to bring the system to a known baseline, otherwise I feel things can get too confused and irreparable. At least now, the system is usable.

Thanks again!

  • Itai

You need to track down all the drivers you have installed and remove them and then start from scratch.
If you say the repo drivers give no joy, try the latest ati driver here:
ATI Catalyst™ Proprietary Display Driver
To install these, you need the kernel headers, so install the development kernel modules.
At the same time, get the release notes and have a read through them. From memory, there is a section that will tell you where all the driver files ate located and a piece that tells you how to initialise the driver - something like aticonfig --initial)
To save problems, track down where your drivers are located and switch to runlevel 3 to delete them. (Log in as root)
The repo drivers are easy to uninstall - do it from yast2>software and uncheck the driver. The ati drivers need you to delete them manually.
Still in runlevel 3, cd to the folder you have saved the ati driver and run it. (type: sh ./(atiinstaller_file_name).run)
Don’t choose the generate rpm option. Use the defaults for everything else.
Once installed, run the initial setup as detailed in the release notes and reboot to runlevel 3.
login as root again and run sax2 -r -m 0=fglrx and configure the card.

Look at this thread:
ATi Drivers OpenSuSE 11.x (Updated) - openSUSE Forums

Thank you so much!

The solution was to uninstall two drivers (one from ATI’s site and one from the ATI repo) and install only one (the one from ATI’s site).

I guess the two drivers were conflicting which probably occured when I installed the wrong one after the last kernel upgrade. I guess this also means I have to keep reinstalling ATI’s driver after each kernel upgrade, since that is one that worked :frowning:

  • Itai

Glad you gotit working.
Remember to reconfigure it next time the kernel changes.