Yes, I have a problem with my wireless and

following the pinned guidelines here is what I see.

Opensuse 13.1
KDE 4.11.5



Result of /usr/bin/lsusb (snipped)
Bus 001 Device 003: ID 0a5c:21d7 Broadcom Corp. BCM43142 Bluetooth 4.0
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 005: ID 0bda:58c2 Realtek Semiconductor Corp. 



Results of /sbin/lspci (snipped)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
02:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)

Results of /sbin/lspci -n (snipped)
01:00.0 0200: 10ec:8136 (rev 05)
02:00.0 0280: 14e4:4365 (rev 01)

14e4:4365 rev01


Result of dmesg | less (snipped)
    1.630992] usb 1-1.1: Product: BCM43142A0
    1.630994] usb 1-1.1: Manufacturer: Broadcom Corp
    1.630996] usb 1-1.1: SerialNumber: F82FA8DF401E
    1.704009] usb 1-1.3: new high-speed USB device number 4 using ehci-pci


and then there are these:


Sunhui-PC:~ # iwconfig
lo        no wireless extensions.

enp1s0    no wireless extensions.

The wireless adapter is “on” in BIOS
As an aside, wired works which is why we have not noticed the wifi problem until now.
Bluetooth sorta works though it will not discover any devices.

I tried the download and run of


Sunhui-PC:~ # sudo bcm43xx_firmware/install_bcm43xx_firmware_no_net

and the 2 directories still remain empty.

I know not what to do and am willing and able to try anything.

thanks

Further info, posted cause it looked helpful.

Sunhui-PC:~ # lspci -vnn -d 14e4:

02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
        Subsystem: Dell Wireless 1704 802.11n + BT 4.0 [1028:0016]
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at c0500000 (64-bit, non-prefetchable) [size=32]
        Capabilities: [40] Power Management version 3
        Capabilities: [58] Vendor Specific Information: Len=78 <?>
        Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [d0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [13c] Virtual Channel
        Capabilities: [160] Device Serial Number 00-00-a8-ff-ff-df-f8-2f
        Capabilities: [16c] Power Budgeting <?>
        Kernel driver in use: bcma-pci-bridge
        Kernel modules: bcma

This box was originally Windows 8 and I installed 13.1 onto it.[/size]

And one more.

I plugged a USB D-Link adapter into a USB port and it connects just fine.

That says to my uneducated ears that the Broadcom driver is not working.

Well I’ll be darned. That seemed to fix it. Now to see if I can get the wired to work again.

Both wifi and wireless work well and I was hoping that with the proper driver that it would solve my Bluetooth issue but alas, no joy.

So, I am off to see if I can figure it out.

I spoke too soon about the wifi working.

It worked when I plugged in an external USB wireless adapter.
And I have removed and re-installed the Broadcom-wl and Broadcom-wl-desktop and it made no difference.

And being a heretic, in an attempt to get bluetooth working I was testing an Ubuntu version with a beautiful desktop named “Elementary Luna”.
Elemenrary Luna installed a different driver which worked for the Wifi and I was wondering how to install it in Opensuse 13.1

It is :

These packages contain Broadcom's IEEE 802.11a/b/g/n hybrid Linux® device driver for use with Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43224-, and BCM43225-, BCM43227- and BCM43228-based hardware. There are different tars for 32-bit and 64-bit x86 CPU architectures

Link here http://www.broadcom.com/support/802.11/linux_sta.php

So, how do I go about installing and trying it with openSuse 13.1 ?

thanks.

PS, posting this reply as its own thread.

I replied in your other thread.

Just one thing here as well: broadcom-wl is in fact that Broadcom STA driver.

And you probably should have mentioned what device you have in the new thread.
Not everybody that reads the other thread will know that you already posted it here.