YaST2 - System Services

Hello List,

Upgraded last Monday 8 PCs from openSUSE 11.3 → 12.1, KDE desktop, identical software stack.
All machines show in Yast2 - System Services the following entries, among others:
Service Running B 2 3 5
named Yes 3 5
network Yes B 2 3 5
nfs Yes B 3 5
xinetd Yes B 2 3 5
No problems until last Friday. Then ONE machine, after booting, showed the services above NOT running.
Changed the permissions as to start these services at boot time, and restarted the services manually, rebooted (cold boot), same result. Although network is reported to be NOT running, a ping to any PC in the network is successful. However a new problem cropped up. Clicking the Expert Mode radio button in System Services resulted in a total freeze of the system.
Performed a fresh installation. Problem persists.
Any idea what this can be?
I still have to upgrade three more PCs for this customer (Sunday) but am hesitant to do so.
Any suggestion is welcome.

Dick Davis

A hunch based on some network issues encountered in 12.1: Try uninstalling the RPM systemd-sysvinit and replace it with sysvinit-init. This is reversible if it doesn’t help.


Will do so, tomorrow when I am at the office.
Hope it will work.
Will keep you informed.

Dick Davis


I tried your suggestion, no luck.
I checked all upgraded systems, included my “test” computer and out of eight systems only two come up with this problem. FIY in order to be sure that every computer has the exact same setup, i had a list with additional software, setting etc. to accommodate my client’s needs. BTW checking the system showed that sysvinit, sysvinit-init, sysvinit-tools, syslog-service, systemd, and systemd-presets-branding-openSUSE are installed installed on both the good working systems and the two failing ones.
Any idea what else could cause this?

Dick Davis

Just guessing,

Especially after each and every upgrade, have done proper updating using zypper? Note this is one scenaio Apper will not do what you want.

$ zypper up


Also check whether ipv6 was disabled on 11.3. If so, disable it on 12.1 as well.

Question: how did you upgrade? 11.3 -> 12.1 is officially a no-go. Clean install? then we can exclude that.

Thanks for the comments.
Update was performed from a DVD. Apper is not installed.
Upgrade from 11.3 -> 12.1 results in problems on only 2 machines. Three other upgraded boxes are fine. One fresh install causes problems.
Also, this morning on another box with 11.3 installed the network, nfsserverver and xinetd were not started and all options in xinetd were disabled. Manually started these functions, no errors.
Will perform a clean install of 12.1 and keep ya’ll posted.
Dick Davis.

Thanks for the tips.
Upgrades performed using DVD. Apper not installed.
Some upgraded boxes (11.3 -> 12.1) do work correctly. This problem is on both an upgraded box, and one with a clean install.
This morning, another box running 11.3 had problems starting the network, nfs, and xinetd. Manual start, no errors.
Will do another fresh install, on a new clean disk.
Keep ya’ll posted.

Dick Davis


IPV6 is disabled. Always was.
Box1 - was upgraded from 11.3 → 12.1 - reinstalled sysvinit-init.
Result: OK
Box2 fresh installation, used the same DVD as for box1 and other fresh installs.
Result: Crash in Yast - System - System Services when choosing Expert mode.
Deleted and reinstalled after booting: yast2-runlevel and
Crash message:
$ybindir/y2base $module “$@” “SELECTED_GUI” $Y2_GEOMETRY $2UI_ARGS

What can be the fix?

Thanks (again)
Dick Davis

I repeat, any other “updating” like what runs from the DVD is likely insufficient. You must run the zypper update.


I believe what you say about updating with zypper. However, as I posted Box1 is now working perfect. I made a fresh install on Box2, using a DVD, that caused the described crash. Do you suggest to use zypper to correct this problem, and to run it also on Box1? I am more than willing to do it, but I like to know the “why” as to not feeling like a trained monkey.

Hope you can help with some answers.
Dick Davis

Broken things get fixed from the update. ie bugs are found and fixed.

Thanks gogalthorp.
One is NEVER too old to learn!!!

Dick Davis

Well, I used zypper as suggested and even created a disk with openSUSE 11.4.
Still the same crash in YaST System Runlevel.
Installed drive with 12.1 (crashed) in another box.
Ditto for the drive with 11.4. Upgraded 11.4 -> 12.1 with zypper. NO PROBLEM.
Must have been a hardware failure. What failed? I don’t know, but for the moment everybody is happy.
Thanks for all the suggestions.
Have a nice weekend.
Dick Davis