Yast2 Software Manager crashes after installing KDE 4.2.2

Hi,

I installed KDE 4.2.2 (factory) recently. OpenSUSE 11.1 with latest kernel, previous version of KDE 4.1.3. Everything went fine and I’m loving it. However, I noticed one problem: when I try an update through Yast2 software manager, in Package > All packages > Update if newer version available, the software manager freezes. I have to do a force quit and then kill y2base in system monitor to get it working again.

Has anyone else experienced this and found out what causes it? Thanks.

You should be using this repo now really
Index of /repositories/KDE:/42/openSUSE_11.1

and
Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42

As Factory is going to run 4.3
(which will be a little unstable for most) Some are already using it, but they are experienced users.

You might want to post

zypper lr

so we can see what you have in repos

Here are my repos:

pastebin - Unnamed - post number 1413122

Delete 1
Leave 2

add the community
Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42

then do update all unconditionally in the kde42 and community42

edit:
You can run yast from outside the UI - boot to level3 and go su
start yast with:

yast

it’s keyboard navigation

Thanks for the help, really appreciate it.

Trying that, with the KDE:42 repo I get a lot of dependency problems, with the ‘the following actions will be done’ involving lots of downgrading of packages to 4.1.3. Should I still pick that option or rather ‘do not install’ or ‘ignore dependencies’? Thanks again.

Make all your repos have the same priority
set them all to 99
except oss and non-oss, set them to 120
Most of them will be already be 99, updates will probably be 20 - change it to 99

Now try

That solved it, thank you again.

Phew!
What a relief. Well done!