Yast2 Software Management refuses to work

Each time I launch yast2 sw_management a dialog pops up saying “There was an error in the repository initialization.” and none of the repositories are visible. If I go to configuration->Repositories I see them all and if I refresh all of them and return I now see them. However, if I select something and try to install it I get the following error message:

terminate called after throwing an instance of ‘std::runtime_error’
what(): locale::facet::_S_create_c_locale name not valid
YaST got signal 6 at YCP file String.ycp:150
/sbin/yast2: line 427: 25094 Aborted $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

This is with OpenSUSE 12.1.

aaronw2 wrote:

>
> Each time I launch yast2 sw_management a dialog pops up saying “There
> was an error in the repository initialization.” and none of the
> repositories are visible. If I go to configuration->Repositories I see
> them all and if I refresh all of them and return I now see them.
> However, if I select something and try to install it I get the following
> error message:
>
> terminate called after throwing an instance of ‘std::runtime_error’
> what(): locale::facet::_S_create_c_locale name not valid
> YaST got signal 6 at YCP file String.ycp:150
> /sbin/yast2: line 427: 25094 Aborted $ybindir/y2base
> $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS
>
> This is with OpenSUSE 12.1.
>
>

Open a terminal

su -
yast2

Hi, I also have the same problem. I use openSUSE 12.2. I solve it with downgrading package glibc.

The story begin while I want to install newest Postgresql 9.2. This application need glib 2.16 (available version in my computer is glib 2.15).
So, i upgrade my glibc to the 2.16. This upgrade also need upgrade glibc-locale (Locale Data for Localized Programs) to the version 2.16.

OK. Postgresql successfully installed. But, I got crash with YaST packed manager. I guest upgrading glibc-locale coused problem into our YaST.
Finally I decide to remove Postgresql and downgrading glibc. Since YaST packed manager can’t work properly, I used command zypper to do that, with:

# zypper remove glibc

Don’t worry, this command will not remove your glibc actually, at least that’s what happened on my computer :smiley:

Good Luck!

On 2012-12-07 16:46, nagapuspa57 wrote:
> Hi, I also have the same problem. I use openSUSE 12.2. I solve it with
> downgrading package glibc.

Touching that library is dangerous.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Oo… Really?? Before this, I really don’t know if we did something with this library can make serious probelm onto our system, hehehe…
Thx for share :smiley:

For anyone having problems with YaST applications not wanting to run while using openSUSE 12.2, you might consider upgrading to YaST from its head repository.

Index of /repositories/YaST:/Head/openSUSE_12.2

To fully upgrade, including the files from YaST and Packman, I would do the following tasks for openSUSE 12.2 using KDE:

  1. Go to YaST (Enter Root Password) / Software / Software Repository and specify the URL addition of the Packman Repository “http://packman.inode.at/suse/openSUSE_12.2/” excluding the quotes only if not already done, else skip this.
  2. Go to YaST (Enter Root Password) / Software / Software Repository and specify the URL addition of the YaST-Head Repository “http://download.opensuse.org/repositories/YaST:/Head/openSUSE_12.2/” excluding the quotes.
  3. Go to YaST (Enter Root Password) / Software / Software Management and select Options and check Allow Vendor Change.
  4. Again, still in Software Management select Package / All Packages / Update if newer version available and press the Accept button on the bottom right.

Without messing with any other settings I have had YaST restored to full function and not falling back later. I have not attempted to determine why this problem might occur to YaST and in each case the main YaST program loads, but separate applications fail such as hardware / Sound.

If you can not get YaST / Software / Software Repositories or Software Management to run then you must use zypper in terminal:

su -
password:

zypper ar http://download.opensuse.org/repositories/YaST:/Head/openSUSE_12.2/ YaST
zypper refresh
zypper mr -rk -p 35 YaST
zypper update
zypper dup --from YaST

Either way, once YaST is updated, you might want to restart openSUSE and see what you get. At least for openSUSE 12.2 installs, I have started doing a preempted upgrade of YaST before any troubles strike as you may be unable to use the GUI version later if you do not.

Thank You,

Will this also resolve the issue with the newer glibc?

Leslie

glibc is not part of the YaST repository and so adding it would not solve that issue I believe. However, what problem do you have or are referring to?

Thank You,

Some time ago there was an issue on 12.2 with glibc update from the updates repo, If I recall correctly, YaST would not start with this issue (amongst other things)
It affected a few, my SUSE studio builds were affected, but not my installed 12.2. https://forums.opensuse.org/english/other-forums/development/suse-studio/481559-bash-warning-setlocale-what-do-i-need.html

The updated glibc issue was long ago solved.

Okay. The reason I ask is, my YaST is failing in a similar way; it dies while doing the repository refreshes with an uninformative popup message:


Warning
 An error occurred during repository initialization.
OK

The only things that I have upgraded beyond the standard products is the gcc suite (gcc-4.7-2.1.1), glibc (glibc-2.15-22.17.1), and ncurses (libncurses6-5.9-12.5.1). I can’t see that gcc would have an effect on YaST, but perhaps one of the other two is causing my problem?

During the release cycle of openSUSE 12.2, I have had a LOT of issues with one or more YaST functions dying. Either they fail to run at all, or some option in it causes it to die. At first, I add in the YaST:Head repository, and that worked, mostly, but recently, I had an up-to-date copy die and so I tried something new. First off, I was never without the ability to use YaST Software Management or if not, Zypper was working. So, on the most recent problem, I would remove the YaST:Head repository if it was added, then I went into Software Management, selected Repository View and did a Switch System Packages to the openSUSE Update repository. That worked though I had to switch a few things back to Packman. So, besides any important libs, some system updates are not updating everything that needs updating for YaST. If a Switch System Packages works, something is not being loaded that should be, but just what that might be, I am not for sure.

Thank You,

Ah. I thought that I had just somehow broken my YaST, but now I find out that I’m not alone. :slight_smile:

It turns out that only my GUI version is broken; the command-line version works fine. Now, if I could just find out how to get it to install *.ymp packages via the command-line version, I’d be home free.

You appear to know a lot more than I do about repository manipulation. I didn’t know there was such a thing as the YaST:Head repository, and I’m not sure how that Switch System Packages thing works, but I’ll give them a try.
Thanks for your help!
Leslie

Well, I tried going into (GUI) YaST Software Repositories==>Add==>Community Repositories, but all I see there are the openSUSE Build Services repositories, plus the Nvidia repository. I Googled “opensuse yast:head” and found some links, but I haven’t found a URL that I recognize could work in the Add Repository dialog, and nothing there explains how to add it. (?)

These are the repositories currently active on my system:

$zypper repos
#  | Alias                             | Name                                    | Enabled | Refresh
---+-----------------------------------+-----------------------------------------+---------+--------
 1 | Packman Repository                | Packman Repository                      | Yes     | Yes
 2 | SuSE                              | SuSE                                    | Yes     | Yes
 3 | VLC                               | VLC                                     | Yes     | Yes
 4 | X11_RemoteDesktop                 | Remote Desktop software (openSUSE_12.2) | Yes     | Yes
 5 | download.opensuse.org-Extra       | openSUSE BuildService - KDE:Extra       | Yes     | Yes
 6 | download.opensuse.org-KDE3        | openSUSE BuildService - KDE:KDE3        | Yes     | Yes
 7 | download.opensuse.org-Stable      | openSUSE BuildService - LibreOffice     | Yes     | Yes
 8 | download.opensuse.org-UpdatedApps | openSUSE BuildService - KDE:UpdatedApps | Yes     | Yes
 9 | download.opensuse.org-Wine        | openSUSE BuildService - Wine CVS Builds | Yes     | Yes
10 | download.opensuse.org-oss         | Main Repository (Sources)               | Yes     | Yes
11 | libdvdcss repository              | libdvdcss repository                    | Yes     | Yes
12 | openSUSE-12.2-1.6                 | openSUSE-12.2-1.6                       | No      | No
13 | openSUSE_Fonts                    | openSUSE Fonts                          | Yes     | Yes
14 | opensuse-guide.org-repo           | libdvdcss repository                    | Yes     | Yes
15 | packman.inode.at-suse             | Packman Repository                      | Yes     | Yes
16 | repo-debug                        | openSUSE-12.2-Debug                     | Yes     | Yes
17 | repo-debug-update                 | openSUSE-12.2-Update-Debug              | Yes     | Yes
18 | repo-debug-update-non-oss         | openSUSE-12.2-Update-Debug-Non-Oss      | Yes     | Yes
19 | repo-non-oss                      | openSUSE-12.2-Non-Oss                   | Yes     | Yes
20 | repo-oss                          | openSUSE-12.2-Oss                       | Yes     | Yes
21 | repo-source                       | openSUSE-12.2-Source                    | Yes     | Yes
22 | repo-update                       | openSUSE-12.2-Update                    | Yes     | Yes
23 | repo-update-non-oss               | openSUSE-12.2-Update-Non-Oss            | Yes     | Yes
24 | trinity                           | trinity                                 | Yes     | Yes
25 | trinity-noarch                    | trinity-noarch                          | Yes     | Yes

Thanks for your help!

Leslie

When my YaST installer fails i usually do this and it works in 99% of the time


zypper clean
zypper clean --all
zypper refresh -fdb <==This forces a complete refresh and rebuild of the database, including a forced download of raw metadata. 

Also if you disable all repos using below command ,your YaST should start as error seems to be in “initialisation of repo”

 zypper mr --disable --all

YMP is just an xml file . Not a binary format
Open it in text editor and check what repository it is trying to add and what software packages it is trying to add
You may always add repos and install packages through zypper

i think this may the head thing
http://download.opensuse.org/repositories/YaST:/Head/
Depending on openSUSE version you do something like this

zypper ar -f http://download.opensuse.org/repositories/YaST:/Head/openSUSE_12.2/YaST:Head.repo 

If the previous suggestion does not work, you can give this a try:

zypper ar http://download.opensuse.org/repositories/YaST:/Head/openSUSE_12.2/ YaST
zypper refresh
zypper mr -rk -p 35 YaST
zypper update
zypper dup --from YaST

Thank You,

Fixed! I ran the above 4 zypper commands and my (GUI) YaST is once more working.

Thanks (and how do I mark this thread as fixed?)

Leslie

You can add a solved tag
Refer:- SUSE Paste

The overall thread title can’t be modified, but I can add Solved to the message thread tags and to my single message title. I am happy to hear we formulated a fix for you.

Thank You for using openSUSE,