YaST2 says 15GB of disk is too small

Hi Suse community :)!

I’ll get to the point straight away… I’m trying to install OpenSuse 11.2 on a HD that already has Win 7 on it.

I left out 15.52 GB of space just to install Opensuse but when I select that partition (which of course is empty) and tell YaST2 to install OpenSuse there it tells me there isn’t enough space. Is 15 GB not enough!? Minimum requirements where supposed to be 3GB I think…

Thanks for your help :)!

PS this is how the disk is devided… Primary partition of 50GB for win 7, 400 of Logic partition for Programs, and supposedly 15GB for OpenSuse…

We would need to see real information
If you have a live cd of linux, any will do. Boot it, when at the desktop, open a terminal become su and do:

fdisk -l

post result

Apart from the info we need as caf4926 asks for, I hope you are aware of the fact hat you need at least two partitions? One for Swap and one for the system (would not be bad if you told also what the size of your memory is).

Okay sooo… I tried to use an Ubuntu 8.10 LiveCD I had lying around to do the fdisk -l thingy and it said:

unable to open dev/sda
unable to open dev/sdb

I wrote sudo fdisk -l in the command line, doing something wrong?

Anyways the funny thing is I had 5GB of space in the dev/sdb and he would install it there while in dev/sda I have 15.51GB of space left and he says there isn’t enough space.

On sda I have 2 primary partitions:

100MB of System reserved, Win 7 did this

50GB wih Win7 OS

and 1 secondary of 400GB which I used entirely to make a logic partition.

I have 465GB in the hard disk (usable) so I have 15.51GB left.

On sdb I have only one primary partition (20GB) with WinXP and one secondary with a logical drive of 440GB… this leaves about 5.5GB free.

Why the hell is YaST ok with installing itself in the 5GB if I tell him to but he isn’t with the 15.5GB? I tried both formatting them or leaving them un-formatted.

I have 2GB of DDR2 and a pentium D820, computer works well with Win7.

PS I know it needs the two partitions but he creates them on it’s own I presume… it did when I told him to install in the 5GB space on sdb… why not on sda???

fdisk -l is done in su terminal

Become su in Terminal - HowTo - openSUSE Forums

Problem solve guys :slight_smile: I was doing the most stupid mistake ever… trying to put 5 primary partitions into 1 drive (max 4 allowed)

Thanks for you help anyways :wink: cheers :slight_smile:

DUDE! lol!