Yast2 / ruby error after new install

Hi, again. I’m sorry I always seem to show up when something terrible happens (erm… happens to me, actually).
After being unable to recover my past Tumbleweed installation, I managed to save the files that weren’t already in a backup drive, and re-install tumbleweed. I did so with difficulty because HP likes giving people trouble, but I ended up with a somehow operational Tumbleweed installation that recreated my user based on my previous user profile. So far, so good. However, when I try to open yast, it gives me an error and closes.

2018-02-11 17:13:35 <3> linux-9geu(714) [Ruby] yast/wfm.rb:276 Internal error. Please report a bug report with logs.
Run save_y2logs to get complete logs.
Details: Failed to load Module 'Packages' due to: Failed to load Module 'SourceDialogs' due to: Failed to load Module 'CWM' due to: cannot load such file -- abstract_method
Caller:  /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'

Can you please help me figure out a solution?
I am using the 4.15 latest kernel, and I didn’t get any errors while installing.

I am finding other errors in the system as well, but I suppose I must open a separate thread for them.
Thanks in advance for any kind help you can provide.

I was looking around the Internet and nothing suggested in the past seems to be working for this problem I have now.
I still cannot use Yast at all.
I was wondering if anyone has any clue about what could help? I don’t want to go for yet another fresh install. My HP notebook makes sure it is a nightmare to even try.

This has the symptoms of a bad install.

 # zypper lr -d -E
 # zypper dup -d 
 # zypper dup

Are you trying to use a graphical YaST? Diagnostics are often easier using a text-mode (ncurses) instance. E.g. –

 # yast repositories
 # yast sw_single
 # yast

Try using a known repository-mirror: e.g.

Hi, Eng-int, thank you very much for your kind reply.
I’ve tried graphical yast and ncurses yast, and both give me the same error.
I think maybe the problem is connected with HP allowing me to boot from a usb-stick, but not allowing me to install from that kind of media. (Their UEFI /Legacy is rather confusing, and some options cannot be changed. While I can change the boot order, it doesn’t seem I can install from anything other than hard drive). So my hard drive has a partition sda2 where I burnt the install media 2 years ago when I installed openSUSE for the first time on this notebook.
When I had to re-install the system after the many problems with the botched zypper dup, it used a combination of THAT install media from 2016 and packages available over the net, but nothing from the usb-stick I had burnt minutes before.

I’m thinking I might need to dd the contents of that usb-stick into sda2? I also notice I seem to have duplicated repos, which I don’t think are the main cause of the problem but they might be a bit of an annoyance? I’m posting the repos list just in case:

Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                            | Name                      | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                            | Service
 1 | Fonts                            | Fonts                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/M17N:/fonts/openSUSE_Tumbleweed      |        
 2 | Games                            | Games                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_Tumbleweed/           |        
 3 | Non-OSS                          | Non-OSS                   | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                          |        
 4 | OSS-update                       | OSS-update                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                |        
 5 | Packman_Essentials               | Packman_Essentials        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/Essentials/ |        
 6 | Science                          | Science                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/science/openSUSE_Tumbleweed/         |        
 7 | download.opensuse.org-non-oss    | Main Repository (NON-OSS) | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                          |        
 8 | download.opensuse.org-oss        | Main Repository (OSS)     | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                              |        
 9 | download.opensuse.org-tumbleweed | Main Update Repository    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                |        
10 | openSUSE-20161226-0              | openSUSE-20161226-0       | Yes     | (r ) Yes  | Yes     |   99     | yast2  | hd:///?device=/dev/sda2                                                        |        
13 | skype-stable                     | skype (stable)            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://repo.skype.com/rpm/stable/                                             |        
14 | skypeforlinux                    | skypeforlinux             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://repo.skype.com/rpm/stable 

Thanks in advance for any help you can provide!!

ruby and YaST packages have recently been updated. You almost certainly have conflicting versions.
If you need to use a variey of alien software (especially proprietary) you might be better withh Leap than TW.

Becauase it changes so frequently, TW DVD images are of limited usefulness. If you plan another clean install it would be useful to download the NET image directly to sda2 and boot from there.

For now disable all repositories except repo-oss and Packman, then zypper dup. If you network connection is not good, consider download-only then install to avoid a broken downloasd-install.

 # zypper mr -d 1 2 3 4 6 7 9 10 13 14
 # zypper dup -d
 # zypper dup

You can try installing the other stuff after you have a useful system. In my experience other repositories are often out of sync with the current main TW repo.

IMO good advice,
But for the uninitiated, it might be useful to provide comments for the commands you ask to be run, so they understand what is happening at each step…

So, for instance…

The objective of the following commands is to do an in-place upgrade, if all goes well this is likely your easiest option.
Downloaded packages should over-write any problem packages that exist on your system now.

You should run the following commands one after the other

This command disables all repositories except the one you need to upgrade. you can re-enable the disabled repositories later and upgrade anything from those repos later

# zypper mr -d 1 2 3 4 6 7 9 10 13 14

The following command downloads all the packages needed for your upgrade, but doesn’t run the upgrade. This is useful if you have a slow or unreliable connection so your upgrade won’t be interrupted due to network problems. This is roughly equivalent but better than your idea of copying the contents of your USB stick to your hard drive.

 # zypper dup -d

The following command executes your upgrade.

 # zypper dup

After all this, reboot and try to open YaST again.


The install image in the repo list is over a year old …

So, maybe the User should permanently remove the repo listing for the DVD with the following command

zypper rr 10

I’d guess that doing an online upgrade should resolve problems related to the ancient DVD image anyway…


Thank you so much! This worked perfectly.
I removed the duplicate repositories (I probably re-added them without considering I was recreating my user based on my old user) and permanently removed the Fonts and Games repos, both of which were added for my nephew to install games on my computer. A bad move, I admit. Now that, at the ripe old age of 8 years old, he has his own computer, auntie can live without those. =D

Thank you, once again! You are brilliant!

Can u please post step by step process of how u resolved this??

In general, the SOP for performing an online upgrade which is described at https://en.opensuse.org/SDB:System_upgrade

Procedure is to first disable or in this case chose to uninstall all unnecessary repositories first. The necessary repositories are the OSS and OSS update repos, optionally should not be too risky to include the Non-OSS and its Non-OSS update repos.

Depending on the situation, convert the existing repos to the version of openSUSE you want to upgrade to… If you’re performing a re-installation rather an upgrade from another openSUSE version, the repos should already be named correctly. A sed command in the above SDB can help you modify repo names if necessary.

Then, do your “zypper dup” to execute the upgrade/repair/re-installation.
If you’re queasy about doing this step which can be hard to undo, you can also download all packages beforehand (as described above) when your Internet connection is unreliable or do a test run.

Reboot and see what your results are.
Again, refer to the SDB link for full details.

If successful, then you can choose to re-enable repositories (don’t forget to make sure that each are for the proper openSUSE version) and “dup” again (because this is TW) to update applications and components from those repos as well.


Whenever being lost, it helps to disable all but the following repos:

erlangen:~ # zypper -D /Tumbleweed-HDD/etc/zypp/repos.d/ lr -uE
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias                            | Name                      | Enabled | GPG Check | Refresh | URI                                                  
1 | download.opensuse.org-non-oss    | Main Repository (NON-OSS) | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/non-oss/
2 | download.opensuse.org-oss        | Main Repository (OSS)     | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/oss/    
3 | download.opensuse.org-tumbleweed | Main Update Repository    | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/tumbleweed/      
erlangen:~ # 

First run zypper dup. Only then add more repos one at a time and always dup.