yast2:curl:"problem 2 bad chunky"

using the current CD installation of 11.0, I got stuck behind my proxy when using “yast” and “curl” to update the distribution packages.

“curl” scoffs with this “problem 2 bad chunky”.
I tried to add in /root/.curlrc:


and the ‘curl’ command line worked again,
but ‘yast’ still would not take into account the changes in

can we use ‘wget’ with ‘yast’ instead?
or where to change this python-curl stuff to ingest the ‘.curlrc’ configuration?

please help!

and to add a bit of log,

…(31538) [zypp] MediaCurl.cc(doGetFileCopy):1276 curl error: 56: Received problem 2 in the chunky parser, temp file size 0 byte.
…(31538) [zypp] PathInfo.cc(_Log_Result):292 unlink /var/adm/mount/AP_0x00000001/suse/setup/descr/packages.DU.gz.new.zypp.bsVG5q
…(31538) [zypp] Exception.cc(log):119 MediaCurl.cc(doGetFileCopy):1385 THROW: MediaCurl.cc(doGetFileCopy):1385: Download (curl) error for ‘http://download.opensuse.org/debug/distribution/11.1/repo/oss/suse/setup/descr/packages.DU.gz’:
…(31538) [zypp] Exception.cc(log):119 Error code: Unrecognized error
…(31538) [zypp] Exception.cc(log):119 Error message: Received problem 2 in the chunky parser
…(31538) [zypp] Exception.cc(log):119

which points to the “curl” implementation in the “zypp” package!

any one for an hint or a clue to unstuck this situation?