yast2 - power off during installation - problem

Hi
I was updating some software via yast2. Unfortunately power went off during installation.
Now the system (yast2 with verification mode) tells me I have problem with 3 programs: xvidcore, libvlccore7, libxine2-pulse.
I tried to remove them via yast, via zypper, manually as a root from disk.
Yast still tells me there’s a problem and each time wants to remove them. When I click ok, then it says it cannot be done.
At the same time it says it is both installed and not installed.
I try installing, uninstalling, updating - nothing.
In the yast2 window (tab Versions) it says it has 2 or 3 the same versions installed. But physically on the disk there is one version.
So I guess yast remembers somewhere updating list from before the power went off and tries to ‘finish’ it.
Restarting computer and refreshing repos does not help.

Are we able to solve it?

Please try

su -
zypper clean -a
zypper ref
zypper up

And also try to rebuild your RPM database, as it seems corrupted:

sudo rpm --rebuilddb

Thank you for your responses.

First run of these commands gave nothing.
I had to do it that way:

zypper clean -a

then in yast2 remove problematic programs/libraries

zypper ref

in yast2 install those programs/libraries

and at the moment it seems to be solved

I did logout and log in and right now yast2 does not report any problem
thanks