YaST2 Package/RPM install Help

Hi,
I’m trying to install codecs-kde.ymp and am running into some conflicts. Since I’ve only been using Linux for about a week I can’t seem to figure out what option to choose. The first time I tried I got to following conflict report and Canceled:

YaST2 conflicts list - generated 2008-11-08 19:50:20

ffmpeg-0.4.9.15793svn-20081108.pm.1300.i686 requires libavcodec.so.52, but this requirement cannot be provided
uninstallable providers: libavcodec52-0.4.9.15793svn-20081108.pm.1300.i586[Packman Repository]
libavcodec52-0.4.9.15793svn-20081108.pm.1300.i686[Packman Repository]
] Following actions will be done:
do not install ffmpeg-0.4.9.15793svn-20081108.pm.1300.i686
do not install libxine1-1.1.15-44.pm.0.i686 ] replacement of liboil-0.3.14-18.1.i586 with liboil-0_3-0-0.3.15-0.pm.2.i586
] Ignore some dependencies of ffmpeg

k3b-codecs-1.0.5-0.pm.6.i586 requires libavcodec.so.52, but this requirement cannot be provided
uninstallable providers: libavcodec52-0.4.9.15793svn-20081108.pm.1300.i586[Packman Repository]
libavcodec52-0.4.9.15793svn-20081108.pm.1300.i686[Packman Repository]
] Ignore some dependencies of k3b-codecs
] Following actions will be done:
do not install k3b-codecs-1.0.5-0.pm.6.i586
do not install libxine1-1.1.15-44.pm.0.i686 ] install libtheora0-1.0.final-0.pm.0.i586 (with vendor change)
SUSE LINUX Products GmbH, Nuernberg, Germany

packman.links2linux.de

YaST2 conflicts list END

Then I read Concepts - openSUSE and got a little farther. Now I;m getting this:

YaST2 conflicts list - generated 2008-11-09 02:10:35

ffmpeg-0.4.9.15793svn-20081108.pm.1300.i686 requires libavcodec52 = 0.4.9.15793svn-20081108.pm.1300, but this requirement cannot be provided
uninstallable providers: libavcodec52-0.4.9.15793svn-20081108.pm.1300.i586[Packman Repository]
libavcodec52-0.4.9.15793svn-20081108.pm.1300.i686[Packman Repository]
libavcodec52-0.4.9.15793svn-20081108.pm.1300.i586[http://ftp.skynet.be/pub/packman/suse/11.0/]
libavcodec52-0.4.9.15793svn-20081108.pm.1300.i686[http://ftp.skynet.be/pub/packman/suse/11.0/]
] Ignore some dependencies of ffmpeg
] Following actions will be done:
replacement of liboil-0.3.14-18.1.i586 with liboil-0_3-0-0.3.15-0.pm.2.i586
install libtheora0-1.0.final-0.pm.0.i586 (with vendor change)
SUSE LINUX Products GmbH, Nuernberg, Germany

packman.links2linux.de ] do not install ffmpeg-0.4.9.15793svn-20081108.pm.1300.i686

YaST2 conflicts list END

What do I choose? Better yet, how do I just give it what it wants?

Some General Questions about YaST and SPMs:
A conflict like mine above, is this the Linux equivalent of DLL HELL? What is the best way to know what option to Choose? From what i have seen from the 10 or so of these I’ve seen there are 3 choices, Replace with something old, Something new, ignore (and probably end up looking for the file yourself) , or Cancel and ask for help :wink:

Again, I’m new so detailed (or step by step) instructions are very appreciated.

What is the terminal output when you choose the second option?

I don’t know. I haven’t tried because I don’t know how to undo my actions. How can I undo?

if you have VLC repo enabled - disable it

in software management - filter by repo
go to Packman
from the packages Tab along the top
select ‘update all in this list unconditionally’

accept

I tried the update an Get a different Conflict. It seems that what ever the rpm (correct me if it is not the rpm doing this) is looking for a file that is not on the server (in this case Index of /pub/packman/suse/11.0) How do i fix that?

I’m looking for a way to trouble shoot what is going on. I’m not a fan of guess and check because I don’t know how to role back the system state (think system restore in xp) I’d be more adventurous if there was something that could restore me if I foul up.
Conflict report:

YaST2 conflicts list - generated 2008-11-09 21:06:26

kaffeine-0.8.7-2.pm.2.i586 requires libxine1 >= 1.1.15, but this requirement cannot be provided
uninstallable providers: libxine1-1.1.15-44.pm.0.i586]
libxine1-1.1.15-44.pm.0.i686[http://ftp.skynet.be/pub/packman/suse/11.0/]
] Ignore some dependencies of kaffeine
] Following actions will be done:
do not install kaffeine-0.8.7-2.pm.2.i586
do not install amarok-1.4.10-100.pm.1.i586
do not install amarok-libvisual-1.4.10-100.pm.1.i586 ] replacement of xine-lib-1.1.12-8.1.i586 with libxine1-1.1.15-44.pm.0.i686

YaST2 conflicts list END

see if you can mark xine-lib-1.1.12-8.1.i586 to delete

it may auto add libxine1-1.1.15-44.pm.0.i686
otherwise add it

now try the update all I said earlier

I don’t have the xine-lib-1.1.12-8.1.i586. I do have xine-lib-debuginfo and xine-lib-debugsource.

I will try and get libxine1-1.1.15-44.pm.0.i686.

Because I am trying to learn how all this works i have a few questions I hope you can answer:
What does i686 or i586 ect stand for? I get the rest of the file names, cpu?
How did you trace this to xine-lib-1.1.12-8.1.i586 from libxine1-1.1.15-44.pm.0.i686?

Thank you very much for your time. It’s not so much I can’t live without media codex but I want to learn how this all works. I really do appreciate it.

I download libxine1-1.1.15-44.pm.0.i686.rpm and run it and it asks for libxine1-codecs-1.1.15-44.pm.0.i686.rpm who knows what this will ask for.

To me it seems that there is a problem with the YUM file. Then again given how much i know about this I’m leaning toward a fundamental misunderstanding of how it works.

i586, i686… basically it has to do with Machine Architecture
I think this is correct

i386 → means it’s designed specifically for basic intel architecture based on the 80386 (or 386 computers)
i586 → as above but designed for Pentiums and above. Pre-Pentiums may have problems.
i686 → Pentium II and above.

How did you trace this to xine-lib-1.1.12-8.1.i586 from libxine1-1.1.15-44.pm.0.i686?

Just by reading your error message which said:
] replacement of xine-lib-1.1.12-8.1.i586 with libxine1-1.1.15-44.pm.0.i686

In a terminal type:

zypper lr

paste result here

| Alias | Name | Enabled | Refresh

—±--------------------------------------------------------------------------------±---------------------------------------±--------±-------
1 | http://www2.ati.com/suse/11.0 | ATI Repository | Yes | Yes
2 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | Yes | Yes
3 | Main Repository (OSS) | Main Repository (OSS) | Yes | Yes
4 | Index of /repositories/server:/php/openSUSE_11.0 | openSUSE BuildService - PHP | Yes | Yes
5 | Banshee | Banshee | Yes | Yes
6 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
7 | repo-oss | openSUSE-11.0-Oss | Yes | No
8 | Index of /repositories/Mono:/Community/openSUSE_11.0 | openSUSE BuildService - Mono:Community | Yes | Yes
9 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
10 | Libdvdcss repository | Libdvdcss repository | Yes | Yes
11 | Index of /repositories/mozilla/openSUSE_11.0 | openSUSE BuildService - Mozilla | Yes | Yes
12 | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.0 | openSUSE BuildService - OpenOffice.org | Yes | Yes
13 | Index of /repositories/games/openSUSE_11.0 | openSUSE BuildService - Games | Yes | Yes
14 | Main Repository (NON-OSS) | Main Repository (NON-OSS) | Yes | Yes
15 | repo-debug | openSUSE-11.0-Debug | No | No
16 | Index of /repositories/server:/database/openSUSE_11.0 | openSUSE BuildService - Database | Yes | Yes
17 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No
18 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes

I told you to disable the Videolan/vlc repo!!

You have some other crappy stuff in there, but you should be OK once you disable vlc

do the update unconditionally in Packman

Really, I would advise just the following repo’s

Main OS Repo’s and Updates

OSS:
Index of /distribution/11.0/repo/oss

Non OSS:
Index of /distribution/11.0/repo/non-oss

Updates:
Index of /update/11.0

Packman:
Index of /pub/linux/misc/packman/suse/11.0


then
your ATI
http://www2.ati.com/suse/11.0

If you are using kde3? - You could have the kde3 build service

Index of /repositories/KDE:/KDE3/openSUSE_11.0

I’m sorry if I’ve waisted your time. I did not interpret “VLC repo” to be VideoLan.

So now I get more conflict. How does someone navigate all this?

YaST2 conflicts list - generated 2008-11-09 22:16:53

sox-14.1.0-0.pm.1.i586 requires libavcodec.so.52, but this requirement cannot be provided
uninstallable providers: libavcodec52-0.4.9.15793svn-20081108.pm.1300.i586[http://ftp.skynet.be/pub/packman/suse/11.0/]
libavcodec52-0.4.9.15793svn-20081108.pm.1300.i686[http://ftp.skynet.be/pub/packman/suse/11.0/]
] Following actions will be done:
do not install sox-14.1.0-0.pm.1.i586
do not install amarok-1.4.10-100.pm.1.i586
do not install amarok-libvisual-1.4.10-100.pm.1.i586 ] Ignore some dependencies of sox
] replacement of liboil-0.3.14-18.1.i586 with liboil-0_3-0-0.3.15-0.pm.2.i586

kaffeine-0.8.7-2.pm.2.i586 requires libxine1 >= 1.1.15, but this requirement cannot be provided
uninstallable providers: libxine1-1.1.15-44.pm.0.i586[http://ftp.skynet.be/pub/packman/suse/11.0/]
libxine1-1.1.15-44.pm.0.i686[http://ftp.skynet.be/pub/packman/suse/11.0/]
] Following actions will be done:
do not install kaffeine-0.8.7-2.pm.2.i586
do not install amarok-1.4.10-100.pm.1.i586
do not install amarok-libvisual-1.4.10-100.pm.1.i586 ] replacement of xine-lib-1.1.12-8.1.i586 with libxine1-1.1.15-44.pm.0.i686
] Ignore some dependencies of kaffeine

YaST2 conflicts list END

See if you can do the red above

If you can’t manage it from the error you just experienced

Manually click to delete and add the respective packages mentioned there
switch the verify off to just get past the errors temporarily until you are ready to accept

Thank you, it’s working on it.

I see how it could be safe to upgrade xine-lib-1.1.12-8.1.i586 with libxine1-1.1.15-44.pm.0.i686
but how do you know it is safe to liboil-0.3.14-18.1.i586 with liboil-0_3-0-0.3.15-0.pm.2.i586. it seems like an older version.

Also what makes one repository rubbish?

Thanks again for your time and help!

xine-lib to libxine is actually not an upgrade but rather a deletion and replacement with a different package - but it will do the same thing.

liboil is a roll back, which is fine: Basically it’s just that you should really only have multi-media from Packman.

It’s not that the VLC repo is rubbish. All you need from VLC is libdvdcss.

See my comments earlier about your repo list and all you really need!

Thanks again for all your help. The codecs-kds.ymp installed now i have to find out why still nothing works. On to the media forums!