yast2 / Online Update -> "Error while creating client module online_update"


[had accidentally posted this in the German forum; has been moved by one of the moderators to here, but I couldn’t find it - so a repost]

I’ve broken the online update. Best part of it: I even think, I know, how it happened, but I can’t find a way out.

Here are the details:

  1. I started the online update (this worked)
  2. It found a whole batch of available updates, among them one yast/zypper/… update (sorry didn’t care for the details then)
  3. It only selected this update to do this first (as usual); I confirmed and turned away from the computer.
  4. When I look, it just completely hang (a too frequent “unfeature” of Suse 12.1 64 Bit on my system)
    yast2 had updated the packet and stopped during these post installation steps.
    I couldn’t do anything on the desktop (mouse pointer moved, but that was all); couldn’t get to a console, couldn’t kill X11, Ctrl-Alt-Del didn’t get any reaction.
  5. So I power-cycled the machine; it came up again without problem (besides the FS journal playback) - BUT, …
  6. when I now try to start yast2/Online update, I just get “Error while creating client module online_update”
  7. yast (instead of ayst2), as suggested here in other threads, reported the same error
  8. “zypper in -f ‘yast*’” (as suggested in other threads) ended with “zypper: error while loading shared libraries: /usr/lib64/libzypp.so.1003: file too short”

So my current assumption is, that yast2/zypper obviously needed to replace its active files, with the new ones from the patch. This failed half way through and thus now the problems.

First question: Can I start the configure steps, which occur after the installation just a second time (e.g. on the command line) - how ?
(Sorry didn’t note the details of the messages, because I didn’t deem them needed, before the power cycle)
I hope this will fix the problem.

Second question: Any other ideas on that one ?
(Besides trying to remove and reinstall yast & zypper from DVD, which seems rather harsh and also somewhat risky for getting me out of the frying pan into the fire)
This is also nasty, because SW installation entry in both yast and yast2, both fail with the same error message.
And yes, /usr/lib64/libzypp.so.1003 is 0 bytes and unfortunately the only ‘libzypp*’ available there…