Yast2 Online Update: Cannot access installation media

Trying to update my system, I get a message box stating:

Cannot access installation media

(Medium 1).

Check whether the server is accessible.

URL: http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/

Permission to access ‘http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/repodata/repomd.xml’ denied.

Also the pop-up message box that reports “Cannot access installation media” presents choices Retry, Abort, Skip, and whichever one I choose, the message box keeps reappearing. So I have to hurry to kill the update window, usually unsuccessfuly. So it’s difficult to get out of the updater so that I can open the repo manager.

I went into the repo manager and tried to add an http repo for http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/ and also tried to add it as https, but it tells me "Invalid URL:http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/ "

What do I try next?

Now I find that the repo/URL that I tried to add is already in the list, and it is enabled, but still it won’t update.

I have had the same problem and error message for almost a day. It appears to be server problems, but I can’t verify. I am able to ping, but not connect. I have no idea who to report this to.

Attempting to visit http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/repodata/repomd.xml by pasting that address into the browser address box gives 403 Access forbidden error. Same when trying to visit http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/and http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/repodata/

Access forbidden!

        You don't have  permission to access the requested directory.     There is either no  index document or the directory is read-protected.      

If you think this is a server error, please contact the webmaster.
Error 403


Apache/2.4.33 (Linux/SUSE)

Thanks. I installed 15.1 about four days ago, and updating worked okay until now. OTOH, I think that maybe nothing was out of date until now. But I certainly installed without issue many packages (eg latex) that are not installed by default.

Known server problems should be fixed shortly if they haven’t already:

https://mirrors.opensuse.org/ suggests they should already be fixed.

Just a “me too” post verifying the error message and cause…
After years of of reliability, the mirror close to me apparently went bad…
The error of course about inadequate permissions to verify the repository can be confusing,
And a short while later I saw errors about repo metadata not found…

I did a local repository “clean all” to be certain I didn’t have any issue on my machine which resolved the permissions error

zypper clean -a

But when I continued to see metadata errors for <all> my repos,
I simply postponed any updating for several hours.

When the mirror was back up,
A “zypper ref” resulted in a successful repo cache rebuild (because I “cleaned” earlier) and proposed updates.