Yast2 on tumbleweed crashes

I’ve never tried using YaST for my updates.
Nevertheless I am a bit intrigued as you mentioned that it worked before. So, I tried to find a reason for the remark in the wiki to not use yast for updates. It seems that a couple years ago it was still working.
Might be that Tumbleweed hasn’t been around back then.

I guess there is a reason for the updates not workinng through YaST.

that might be right, i’ve only been using tumbleweed for a year or so, before that i was using leap

I see the infamous word “working” (in “It does not work!” and similar).

That is about what one means with “working”.

When one means with “working” that one does not see any problems (until it is too late), that does not mean that it is a good practice.

The same for the good advice: use only zypper dup with Tumbleweed. When you do different, which is your good right, that may “work” for you until the moment your run into problems. Then you can of course come to the forums and ask for help. And people here will help you and give again the advice to use zypper dup only. You may ignore that again. But of course most problems always come up at the wrong moment (and then will be self inflicted).

Updates from Yast only use the updates repo which is not at all the same as zypper up or zypper dup. Generally TW doe not often use the update repo since it is a full distro update

1 Like