Yast2 on tumbleweed crashes

yast2 software update application crashes when i press ‘accept’ for an installed application - i’m using it on tumbleweed

And what happens if you use zypper at a CLI ?

zypper from cli works fine - that is when i use ‘zypper update’ or ‘zypper dup’ - haven’t tried other commands.

That’s the recommended way for updates. According to the wiki the Yast online update module should be only used for patches:


For tumbleweed you should always use sudo zypper dup

I personally don’t use yast for any installations nor updates or patches.

just tried, and zypper -in -n works fine. I just like the gui of yast, but, as you say, i can always use zypper instead. thanks - and i do use zypper on a regular basis to install patches and updates

Does Yast give you an error message when you start it from terminal and it crashes?

it does crash, i think, but running it from a terminal brings up a primitive gui, when i press f10, for ‘accept’ a window flashes up, too quickly to read, then it reverts to this window, to start again

Show your repos:

zypper lr -d

Maybe also check the output from

zypper verify

That’s Yast. (‘yast’ - the text mode)

You would launch the Yast GUI version from a CLI, as in

sudo yast2

when i type ‘sudo yast’ in a terminal, i.e. using the cli, i get the primitive gui as in the image i posted. Typing ‘su’ then from the su cli ’ yast2’ brings up the gui i would like to use, the one that crashes as in my original report. This what this one looks like:

thanks Neil,
zypper verify returns 'Dependencies of all installed packages are satisfied.

what am i looking for in the list of repos? - what i get is

Could you try it with

/usr/bin/xdg-su -c /sbin/yast2

that should launch the GUI. Then please try and reproduce the crash and see if there are any errors shown in the terminal. Not sure if we will get any usable error messages though but it’s worth a try

Too late for the edit:

I did start it myself from terminal and I can reproduce your crash (tried updating alsa). Didn’t get any immediate error but a pointer towards the log file.
So, the respective log should be /var/log/YaST2/y2log

This should be directly before it crashes:

[qt-ui] YQUI.cc(uiThreadDestructor):320 Destroying UI thread
[qt-ui] YQUI.cc(~YQUI):302 Closing down Qt UI.

Don’t see and/or don’t understand what causes it yet.

Could you check your log as well?

A common cause of crashes is when there is a version mismatch with libraries. And this can be caused by a poor choice of repos.

I’m not seeing any obvious problems that might cause the crash.

Repo #5 and repo #6 are the same. You could remove one of them. I’m not sure of repo #8, but I think it is identical to #2.

I would suggest that you disable repo #8 and repo #9, and then try

zypper dup -D --allow-vendor-change

to see if it wants to change anything. Note that with the -D, it will only provide information but won’t actually do any updates.

Again too late to edit:
It’s all a bit cryptic to me but maybe someone else has a bit better understanding.

I found one PID that got SIGTERM-ed:

[zypp::exec++] forkspawnengine.cc(start):274 Executing '/usr/bin/systemd-inhibit' '--what=sleep:shutdown:idle' '--who=zypp' '--mode=block' '--why=Zypp commit running.' '/usr/bin/cat'
[zypp::exec++] forkspawnengine.cc(start):427 pid 9217 launched
[...quite a few lines of log...]
[zypp-core] ShutdownLock.cc(~ShutdownLock):33 Terminate inhibitor lock: pid 9217
[zypp::exec] abstractspawnengine.cc(checkStatus):203 Pid 9217 was killed by signal 15

Is that normal behaviour or connected to the crash?

Edit: Could it be that it’s just normal? As it says here: System Updates - openSUSE Wiki
“Note, this module is only for patches. You cannot update regular packages through it.”

Just tried a regular installation through yast of a previously not installed package and it worked just fine.

yes, my logs show the same thing for [qt-ui], the previous three entries were

[Pkg] y2packager/known_repositories.rb:97 Pkg Builtin called: SourceGeneralData
[Ruby] y2packager/known_repositories.rb(new_repositories):61 New repositories: []
[Interpreter] bin/y2start:68 Called YaST client returned.

i couldn’t see any entries looking like a crash or error report

oh yes, i missed that, i also had the killed by sig 15 entry, and about 20 seconds earlier a number of ‘out of memory’ messages:

[zypp::exec] abstractspawnengine.cc(checkStatus):203 {T:140453515826880} Pid 5226 was killed by signal 9 (Killed; Out of memory?)

maybe a clue there?

and yes, an install of a previously uninstalled package worked fine for me too

unfortunately not, at least not by me.

I really think that is just how it is.

I mean it even says on the wiki that you can’t use it for updates. But if you want to use a GUI for your updates I think Gnome and KDE have their onboard GUIs for that purpose.

1 Like

ah well, many thanks for all your help. In my head i’m sure i’ve used it for updates in the past, but maybe it’s just wishful memories (or a different version of linux)!!

1 Like