Yast2 not opening after update with nvidia & dual screens - possible fix?

I’ve noticed posts about Yast’s gui not opening after updates in various places and I experienced the same problem so I thought I’d post how I resolved it for info and in case it may help someone else

In my case I have two monitors and with just the one enabled yast would open fine, when it stopped opening was if I enabled my second monitor using nvidia-settings, wouldn’t start from the menu and if I tried kdesu yast2 in konsole I would get an error something like no permissions/authority/authentication for display:0

It was actually while putting together a post on the problem that I started enabling and disabling the second display, trying to run yast from the menu and konsole, logging in and out so that I was sure to be posting as much info on the behaviour as I could when I inadvertently hit on what appears to have fixed it

Enabling that second monitor once stopped it opening, decided to try if then disabling it again would allow it to open which it did, I then found that on re-enabling it yast would still open, this second time the problem wasn’t there

So if anyone who uses nvidia-settings to configure a second screen finds yast won’t open, don’t log out and back in as I was initially doing, try doing an Enable – Disable – Enable again thing, it worked for me

I’ve rebooted the machine three times since doing that, turned on the second monitor and Yast’s gui just keeps on opening

I don’t know whether this was happening because I don’t make the setting permanent or not because we use an nis login with an nfs /home from not just this machine but also others some of which have only the one monitor and making the dual-screen setup permanent on those using two screens caused a whole other set of issues

There’s an ati card going in the machine sometime during the next few days so before I get rid of the nvidia stuff I was planning on making the dual screen setup permanent as a test … but I can’t now cos I don’t know how to make it stop working again!