Yast2 no NTLMv2 support? (Proxy settings)

I have been searching the forum and I have found a couple people with similar problems, but no resolution.

I am running OS11 on my desktop. Here in my network I have a Squid proxy server that only allows authentication via NTLMv2. I am finding that in Yast2, under proxy settings, it can not connect to the proxy server. It tries to use basic authentication (which I would like to disable) then NTLM, but never NTLMv2.
Is this a limitation of Yast2 or simply a configuration change I need to make?
The error I receive is:
An error occurred during the HTTP proxy test
Proxy return code: HTTP/1.0.407 Proxy Authentication Required

I do not want to allow NTLM authentication or below on my network, and it is tiresome, always having to add repositories as exceptions in my proxy server.
Is there anyway to make Yast2 authenticate via NTLMv2?

Any help is much appreciated.

Still no resolution to this problem. The only work around I have is to make an exception in my Squid server to not require authentication for any Opensuse repository I am subscribed to. Not what I want to do, but until there is support for NTLMv2, this seems to be the only option.

I have same error. Try to

  1. add “=” in
    vi /root/.curlrc :
    –proxy-user = “name:pass”
    –proxy = “http://proxy_address”

  2. add name:pass@ before all kinds of proxy type in /etc/sysconfig/proxy :

http_proxy=“http://**name:pass@**proxy_address”

it works for me