YaST2 error on first time install macbookair7,2. EFI variables are not supported on this system

Ok, so do you know what they meant with this?

@916p I boot the system with a live USB rescue, then use gdisk to add partitions etc…

What is your proposed layout for the system?

Well with the problems I’m having with the installation I’d prefer dual-boot with MacOS until the openSUSE partition is up and running functionally. Kinda need the laptop to be usable. After that though, the plan is to wipe the Mac partition since the SSD only is 128 GB. If that is what you meant?

@916p OK, I saw in the image, all you need to do is select sda1, select the ‘edit’ button, set to NOT FORMAT and in the drop down select /boot/efi as the mount point, so you share with the existing OS. then can set the rest of the disk for openSUSE.

Well that didn’t work, but I (for clarity’s sake in case I did something wrong) downloaded and tried SystemRescue on a usb and used Gparted to:

  • partition a 60 GiB Btrfs
  • partition a 2 GiB FAT32 to use for swap.

Then I launched the openSUSE installer, opened the YaST2 expert partitioner (using existing partitions) and

  • format the 60 GiB partition to add the subvolumes
  • formatted the 2 GiB into swap
  • edited the existing 200 MiB EFI to not format and selected /boot/efi as mount point.

And now it managed to install and openSUSE is up and running! There’s just one issue – I got this error at the end:

Is the installation borked or does it not matter?

It’s hard to know.

If the system is booting fine, then all is probably good.

You can try:


and if that gives an answer, all is probably ok. If it says that efivars not supported, then something went wrong.

Damn it, I got EFI variables are not supported on this system.

Well at least it’s progress. And I can start familiarising myself with the OS.

Know where to go from here? Reformat and reinstall?

I really don’t know. This may be a macbook issue, and I have no experience with those.

1 Like

@916p I always boot from the cmd/options window on my old MacBook.

Yes I have to do that as well on boot.

But I don’t believe I understand what that means in relation to the errors I got during installation?


Execution of command “[[”/usr/sbin/shim-install", “–config-file=/boot/grub2/grub.cfg”]]" failed.
Exit code: 2
Error output: Installing for x86_64-efi platform.
Installation finished. No error reported.
EFI variables are not supported on this system.
EFI variables are not supported on this system.

I’m assuming this means I’m still doing something wrong at the partition/format stage?

Oh wait. I’m re-reading the thread you linked and am I understanding this comment by @nrickert correctly in that, if the installation usb isn’t set-up correctly, then the whole installation will be incorrect?

If you boot the install media with EFI, then it will default to setup booting to use EFI. If you boot the install media with BIOS booting, then the defualt is to setup the installed system for BIOS booting.

I.e. I formatted and flashed the usb on my desktop Win10 machine which uses BIOS, so the whole installation defaults to that?

Explain what “flashed the usb” means. What did you do exactly?

Sorry, I meant using BalenaEtcher to flash the openSUSE.iso onto the usb.

But I’m now wondering if something about me formatting/flashing it on my Win10 desktop is the problem – if I’m correctly understanding the sentence I quoted in my previous comment. Since Windows uses BIOS? And Linux does not?

I have no idea what it is or what it does, but I am pretty sure that if it involved “formatting” USB, then it was not the right thing to do.

This logical conclusion is wrong.

This program https://etcher.balena.io/

And my apologies, I explained myself poorly. The formatting I did beforehand since it completely erases the previous content which seems like a good idea to me. A clean slate so to speak.

Thank you for the correction on the idea.

I suppose I have some more reading to do now to try and figure out where I’m going wrong unless one of you (oh so patient and kind) fellas know what to do next. Super grateful to you all.

Since openSuSE is quite my favourite distro, and I don’t like the anal fiddling of ubuntu it gives me great pain to proclaim this:
After lots of struggle to install openSuSE on an imac27 I installed lubuntu 2304 with no hastles
Mint is advocated for newbies but I have not played.
Install kwin as the winfdow manager
(nice window decoration and sticky keys)
I installed flash and broke the temperature sensor and installed mbpfan to manage the noise
I was not able to get suspend to work. Shutdown and power button. That’s a biggie, maybe it’s my motherboard.
I found no good mailer, perhaps thunderbird is less worse than most (problems with imap) kmail is pretty but good luck (my VM version sort of worked) but real hardware is less accomodating

1 Like

@jamat13 Have had pretty much the same experience with suspend/sleep on my 27-inch Intel iMac, regardless of which distro I use, as I described in this section of a post about using Linux on that Mac. Am assuming it is, indeed, something specific to an Intel Mac’s peculiar power management vs. that of a PC.

1 Like

One more thing I forgot
Sound is tinny and horrid
Opensuse’s alsa config and alsamixer is a single speaker
Ubuntu gives Front and Base speakers. Taking all from /etc/alsa/*conf and putting them in opensuse /etc/alsa
gives BOTH speakers and you can make sound much nicer.
(Eventually, with great trouble I DID install openSuSE, but it was with great trouble)

1 Like

Sorry! install netboot

1 Like
# efibootmgr
BootCurrent: 0002
Timeout: 3 seconds
BootOrder: 0002,0001
Boot0001* opensuse151
Boot0002* opensuse155
# parted -l
Model: ATA ST1000DM003-1SB1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                       Flags
 1      1049kB  387MB   386MB   fat16           EFI                        boot, esp
 2      387MB   38.3GB  37.9GB  hfsx            sda2 Mac OS X HFS+ system
 3      38.3GB  38.9GB  650MB   hfs+            Recovery HD
 4      38.9GB  500GB   461GB   hfsx            sda4 Mac OS X HFS+ data
 5      500GB   505GB   4429MB  linux-swap(v1)  sda5 Linux Swap            swap
 6      505GB   539GB   34.1GB  ext4            sda6 openSUSE 15.5
 7      539GB   573GB   34.1GB  ext4            sda7 openSUSE 15.1
 8      573GB   1000GB  427GB   ext4            sda8 Linux Home
# inxi -M
  Type: Desktop System: Apple product: iMac7,1 v: 1.0 serial: QP...
  Mobo: Apple model: Mac-F42386C8 v: PVT serial: 1 UEFI: Apple v: IM71.88Z.007A.B03.08...
    date: 03/05/08
1 Like