YaST2 error on first time install macbookair7,2. EFI variables are not supported on this system


I’m in the process of getting away from the big datahoarders and, with my phones already secured with GrapheneOS and DivestOS, next up is securing my laptop (Macbook Air, 13-inch, 2015). For which openSUSE (recommended by Privacy Guides) seems to me to be a good starting point from a usability and privacy perspective. But I am pretty much a complete newbie when it comes to both Linux and command lines – and I want as little to do with commands as possible since it just makes my brain hurt.

As such I have tried following Install openSUSE on a Mac and SDB:Installation on a Mac as well as multiple websearches for the error codes and all the parts of the process I can imagine being relevant. I found no answers (that I could understand anyway), and as far as I can tell my laptop is compatible with openSUSE?

So the error I get is:

Model: MacBook Air, 13-inch, early 2015, model number MacBookAir7,2
CPU: Dual-Core Intel Core i5 1,6 GHz
RAM: 8 GB 160 MHz DDR3
GPU: Intel HD Graphics 6000 1536 MB
OS: Monterey 12.6.9, up to-date.

MacOS disk shrunk and partitioned of 60GB as GUID Partition Map, format ExFAT (correct? wrong? can’t find info on what to use but considering the error feels likely to be part of the problem).

Installation attempted with a SanDisk Ultra USB 3.0 16GB with openSUSE-Tumbleweed-DVD-x86_64-Snapshot20230915-Media.iso, with Sha-256 verified.

Any help much appreciated and thank you very much in advance.

1 Like

exFAT is a proprietary Microsoft filesystem which is not compatible with EFI. It is normally not possible to use it as installation partition with linux…

You should let the automatic partitioner from the openSUSE install media do its job. It will format your disk with btrfs…

This Leap 15.5 guide is valid for Tumbleweed also…

A UEFI machine requires an EFI system partition that must be mounted to /boot/efi. This partition must be formatted with the FAT32 file system.

Is this the relevant part? If so, what format do I want the disk in? Disk Utility only gives me the option to erase/format to APFS, Mac OS Extended, MS-DOS (FAT) and ExFAT. I got the same error before shrinking the MacOS drive (as I do not care about keeping that), which is why I started mucking about with formats since the automatic partitioner seems unable to wipe the old partition for som reason.

Did you boot openSUSE installer in EFI mode?

I followed the Mac guide and did this:

  1. Boot/reboot your Mac.
  2. Press and hold Option key. (Alt key in PC keyboard)
  3. You should see a list of OS boot options.
  4. Choose EFI Boot.

If that is it, then yes.

In installer try to switch to command line (Ctrl-Alt-F2 or Ctrl-Alt-F3, I am not sure) and check whether you have /sys/firmware/efi and /sys/firmware/efi/efivars directories.

The installer opens a command line window with c, if that’s correct.

How do I do that? I am trying to look it up but maybe you can tell me the commands?

ls -l /sys/firmware/efi

TAB completion should work for file names as well.

With the -1 it gives me “invalid file name -l.”, if I remove it I get “/sys/firmware/efi’ not found”.

Am I even doing it right?

It is -l like Lima and not -1 like the number one…

Then apparently you booted in legacy BIOS (or CSM) mode. Hopefully someone more familiar with Mac can offer further advice. I know that in the past Mac used CSM to boot Windows. May be something similar happens here.

Yes, that’s what I typed. With capital letters and underscore instead of space I wrote:


Ok, thank you very much for the assistance. I at least have something specific to try and look up now.

@916p I have an ancient MacBook (3,1 circa late 2007), thats all I did, cmd options and select USB efi boot (the install media on USB), but /boot/efi partition is set to fat… you can do that at the install stage and disk is set to gpt… I did dual boot, but just selcted openSUSE from the MacBook boot menu…

Is it at this stage of the installation you changed it?

And could you more specifically explain how to do it?

@916p Prior to that, at the partitioner… https://forums.opensuse.org/t/installation-on-an-intel-based-macbook-not-a-question-but-rather-an-fyi/143210 I pre-partitioned my disk, then just used YaST expert partitioner and selected use existing partitions and took it from there.

Worth a read https://forums.opensuse.org/t/installation-on-an-intel-based-macbook-not-a-question-but-rather-an-fyi/143210

Thank you. I’ve read that (and this as well as this), but I know to little about partitioning and Linux in general for any of that to be really useful. What I really need right now is some do-exactly-this instructions.

That said, does this look correctly set up:

The EFI and swap I made manually as since I believe they are needed? Really not sure how big they are supposed to be though if that is correct?

So, installer did not offer /boot/efi automatically?

If I use the automatic set-up yes. But that just leads me to the original issue. Which @malcolmlewis said is fixable in Expert Partitioner. I just don’t have any idea what I’m supposed to there so I’m basically guessing and fiddling around.

Very unlikely. If installer does not offer /boot/efi, it thinks you booted in legacy BIOS mode. While you of course can add /boot/efi manually and select grub2-efi as bootloader, you will not be able to create EFI boot entry.

1 Like