yast2 configs my wlan0, same does iwlist, but I can't connect to my router

ok…so I did all that…and unfortunately…to no result…:frowning:

thank you for being this persistent :slight_smile:

Check the driver now
I have to sleep. I’ll check back soon.

Getting Your Wireless to Work

yeah…me too…I have to go to work tomorrow…
thanks :slight_smile:

I would still like to see the result of

/sbin/lspci -nnk

And in the meantime, please put your computers texts between CODE tags: Posting in Code Tags - A Guide to make them readable.

caf4926 wrote this guide himself, thus he seems to be to modest to aks you to follow it.

ok, so…thanks for your prompt responses…
i have to give you an update:

I’ve managed to install a fresh version of OpenSuSE 11.3 because I had some problem with the space on my hdd…

so now… with new install …the system sees my wireless card but I still can’t connect to my router…I’ve tested the connection in windows…and it works perfect… here in linux…although I’m in the same room, it can’t even see the router

the output now is:

30:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11a/b/g [14e4:4312] (rev 01)
        Subsystem: Hewlett-Packard Company Broadcom 802.11a/b/g WLAN [103c:1361]
        Kernel driver in use: b43-pci-bridge

If this is a new install did you do:

sudo /usr/sbin/install_bcm43xx_firmware

then

sudo /sbin/modprobe -v b43

Also if you use kde, I know some folks struggle with the way it manages the network password (or are you not using an encrypted connection?)
Most of use WPA2 and kwallet is used to store the network password.

hey…ok so…in the meantime while you were writing this I installed the drivers from packman…I’ve just rebooted and now…I can’t even see the wireless tab in network manager…
yes I’m using kde, and indeed the connection isn’t encrypted…through my researches I’ve also stumbled upon some threads in which the users complained about the kde network manager…
when I go to Yast2 at the Network settings, I have two options: 1. to let the network manager…manage my connections or 2. to switch to traditional method using ifup
the thing is…I’m a total noob when it comes to linux… and I’m kinda afraid to use ifup command…

now…i’ll use those 2 commands and I’ll get back with an update…
thanks

yes it works…finally :D…
thank you caf4926 :smiley:
thank you very much :smiley:

You need to remove the drivers from Packman, we tried them yesterday without success. Whilst they are installed the b43 driver will not work because the wl driver blacklists the b43

I have to sleep

How exactly…

well…if it is working now…is it necessary to remove those from packman???

and if i’ll be good enough at setting up linux…i’ll be here posting advices for the new users :slight_smile:

Post me the result of

/sbin/lspci -nnk

But I suspect it’s using ‘wl’
Which is fine. Don’t remove anything.

well…i’ve just stared my pc again…and guess what …it won’t see the router…

here is the result…


30:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11a/b/g [14e4:4312] (rev 01)
        Subsystem: Hewlett-Packard Company Broadcom 802.11a/b/g WLAN [103c:1361]

what’s wl and how can you tell if it’s using it???

‘wl’ is the driver you added from packman (broadcom-wl)

That code shows no driver loaded.
I have to go out
Try shutting down the computer completely and starting again.

oh…alright …thanks :slight_smile:

So refresh me as to where you are.

Yesterday…Have you any idea how and why it started working. Did you still have the Packman ‘wl’ driver installed? It sounds like you did. So what exactly did you do that it stopped working. You say “i’ve just stared my pc again…and guess what …it won’t see the router…” But was that from a complete shutdown, hibernate or sleep? Did you do any updates when it was working? I need details.

hey…
I didn’t realise that I’ve mispelled ‘started’, I was tired…so…I started my computer from a complete shut down… I haven’t done anything to it before the shutdown…
the drivers are:


30:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11a/b/g [14e4:4312] (rev 01)
        Subsystem: Hewlett-Packard Company Broadcom 802.11a/b/g WLAN [103c:1361]

…I think they aren’t the -wl drivers from packman…and unfortunatly I still can’t connect to my router… before he shut down… I could…and they were the same drivers…so…???
the sys admin from the company I work for, told me it that it might be a firmware problem… the frimware from win drivers don’t match that from linux driers …or something like that… if I can’t solve the problem until monday I’ll take the computer to work and hopefully he’ll solve it :slight_smile:

Become su -

What does this show?

zypper lu