YAST2 command line - network card config - do not want YAST to write hostname!

Hello,

I’m trying to configure additional network card. Everything works fine, but I do not want YAST2 to write hostname to /etc/hosts, because I do not want changes in /etc/hosts. I would like to change /etc/hosts manually later.

There is an option “│[x] Write Hostname to /etc/hosts”, but i can not put off this [x].

Can anybody help me with this?

Thanks!

Dear matjazs,

Welcome here (I see this is your first post).

Please when you want help, take into account that we here are all volunteers spendind some spare time in helping out fellow openSUSE users. Therefore try to make it as easy as possible for those helpers by telling as much as possible, backed by computer commands and their output whenever possible.

What is missing here in any case is:

. What level of openSUSE are you using? How can we guess?

. What is the exact yast2 command you gave? How ca we find out where you may have made a mistake when we do not see anything?

And something that is not easy to find here, thus we explain it to all newcomers: we like computer text you post to be posted between CODE tags: http://forums.opensuse.org/english/information-new-users/advanced-how-faq-read-only/451526-posting-code-tags-guide.html
And when you post in this way it is best to include the prompt, the command, the output and the new prompt, thus we can see what happened in full extent.

On 2012-03-23 15:56, matjazs wrote:
>
> Hello,
>
> I’m trying to configure additional network card. Everything works fine,
> but I do not want YAST2 to write hostname to /etc/hosts, because I do
> not want changes in /etc/hosts. I would like to change /etc/hosts
> manually later.

Then, do the change yourself later.

> There is an option “│[x] Write Hostname to /etc/hosts”, but i can
> not put off this [x].

tab, tab, tab… till you get to the X.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)


Hello,

I did try tab-tab… but this option is not accessible with tab?
Any other trick?

Thanks

Sorry:

Linux version 2.6.16.60-0.21-smp (geeko@buildhost) (gcc version 4.1.2 20070115 (SUSE Linux)) #1 SMP Tue May 6 12:41:02 UTC 200
8
I start yast2 from command line with #yast2 lan or just #yast2

thanks

Is your network controlled by NetworkManager ? If so disable it or ditch YaST network settings and use the applet or NetworkManager cli.

Best regards,
Greg

What you show is your kernel version (which looks rather old). What I asked is your openSUSE version. When you do not know that (would be very, very strange), do

cat /etc/SuSE-release

And my impression was that you used just a command like

yast2 lan add ..... 

But you seem to use yast2 interactive. That sort of misunderstandings are due to you not telling much and showing even less.

On 2012-03-24 07:16, matjazs wrote:
> I did try tab-tab… but this option is not accessible with tab?
> Any other trick?

Sometimes the label has a letter in bright yellow, those you can use with
the alt key. If there is no highlight, then no luck.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 2012-03-24 10:06, hcvv wrote:
> But you seem to use yast2 interactive. That sort of misunderstandings
> are due to you not telling much and showing even less.

He is using the normal yast ncurses version.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)


ok it is old, but thats the way it is - this is a production server and vendor updates the kernel…

more /etc/SuSE-release
SUSE Linux Enterprise Server 10 (x86_64)
VERSION = 10
PATCHLEVEL = 2

Yes i try to use yast interacive mode and I chose “Traditional method with ifup”.
I can of course edit hosts file later, the problem is that yast would overwrite hosts and also “repair” other hostnames in the host table.

Well, as you can read for yourself, your system is “SUSE Linux Enterprise Server” and this whole forums is dedicated to openSUSE.
My conclusion: you are at the wrong forum. The correct forum is here: SUSE Forums

Now there are some similarities between the two, but be aware of the fact that almost nobody here has SLES running. Thus almost nobody can recreate your problem in the same environment you have. They all have to guess what is going on at yours.
Also there a re a lot of people here that do not even realy know what SLES/SLED is, thus their advises can be well ment, but valid for openSUSE only.

Nevertheless there could be somebody with good advise here, there are some with SLES knowledge around here.

In any case, when you next post computer text here (like the contents of /etc/SuSE-release), pleae opst this by copy/paste between CODE tags: http://forums.opensuse.org/english/information-new-users/advanced-how-faq-read-only/451526-posting-code-tags-guide.html

My mistake, thanks, I was in hurry on friday and choosed the wrong forum. So far I find out that it is better to edit /etc/sysconf/network config file than use YAST. BR