Yast2 branding qt in 13.2?

Hi,

I’m wondering if anybody can tell me how to get the native Qt theme for Yast2 in openSUSE 13.2. Up to openSUSE 13.2, there used to be an alternative official package with native QT branding for Yast2. Now I can’t find that package anymore, neither in my active repos nor on software.opensuse.org.

Any chance of getting that back? I’m personally not the biggest fan of Yast2’s custom theme, it doesn’t blend in well with the Oxygen style and looks dated. Which is why I appreciate being offered a choice. :slight_smile:

The Yast2 qt files (3 files) are there in the repository. On upgrade to 13.2 they were installed by default. I don’t care for the qt look so deleted the packages and selected qt (instead of “auto”) in etc/sysconfig>org>Yast2>GUI. If you don’t have them install, search “yast2” in your package manager and look down the list.

rda

Are you referring to the oxygen icon set used in yast on KDE up until 13.1?
I believe the oxygen icon set in yast has been dropped as of 13.2 - but can’t recall the reason (perhaps it’s to do with the eventual move to KDE5 which has also dropped oxygen).

The reason is just that they don’t want to maintain two icon sets AFAIK.

(perhaps it’s to do with the eventual move to KDE5 which has also dropped oxygen).

No.
Plasma 5 (there is no “KDE5” :wink: ) has not dropped oxygen.
They created a new “breeze” theme which is the default now. But oxygen is still available/included.

But that’s no reason to drop YaST’s oxygen icons. The hicolor icons do not resemble breeze at all either.

Btw, the oxygen icons are still part of the package yast2-branding-openSUSE, they are just not used.

  1. Run Yast2
  2. /etc/sysconfig editor
  3. At left side expand “System”, expang “Yast2”, expand “GUI”
  4. Select “WANTED_SHELL”.
  5. Change “auto” with “Qt”
  6. At left side select “WANTED_GUI”
  7. Change “auto” with “Qt”
  8. Press OK, close yast2, run yast2 again

Thanks everybody for replying!

I was mostly referring to the window style that used to follow the KDE style (or, at least, was Oxygen-themed). The icons are another part, but I figured they were part of the problem! Will they be back once I manage to get the KDE theme applied again? If not, how do I get those back?

Strange that our favorite distro, that adopted KDE software/Plasma, not as default, but as something like a flagship desktop, would cease to support KDE styling in its most important software product. I wonder what they were thinking.

You are right, the packages are still there in the repo! Really weird because I was looking and looking and couldn’t find them. But having the packages doesn’t help when the style doesn’t get applied when I select it.

I wasn’t sure if your “path” description regarding the location in /etc/sysconfig was referring to the file system structure or to the place in the /etc/sysconfig-Editor in Yast. Neither have a folder (or entry) named “org”. Was this a mistake, or could this be the reason it doesn’t apply on my system?

Yast2-/etc/sysconfig-Editor handles the Yast2 GUI in System -> Yast2 -> GUI, where my best guess is we are talking about the strings WANTED_SHELL and WANTED_GUI. Both were set to auto in 13.1, which worked. I have changed the settings to “qt”, but there’s no change.

Set the widget style for root, with “kdesu systemsettings”.
If that doesn’t help, install “systemsettings5” (i.e. the Qt5/KF5 version) and use this.

But no, you won’t get the icons back.
YaST only uses the hicolor ones, as already mentioned.

To the op,
I am not really sure about your question if I understand it correctly.
It might help to take a look at the

qtconfig

It maybe the one you are looking for.
You need to be su to make the changes.

as root user:

cd /usr/share/YaST2/theme/current
mv icons icons.original
ln -s …/…/…/icons/oxygen/ .
mv oxygen icons

close and open again.

sorry for my bad english.

Thanks a lot, fasiko, that worked to get the icons back!

P.S.: No reason to apologize for your English. :slight_smile: