Yast won’t install due to time out

Hi, after installing openSUSE 11.0, I am no longer able to install additional packages with yast.

It worked for a while, but now I am getting an error like

Download failed:
Download (curl) error for ‘http://download.opensuse.org/…’
Error code: User abort
Error message: connect() timed out!

This now happens for most any package I want to install, with different urls. I have checked my network settings, they are fine. Proof is that I am browsing here at this right moment.

Zypper said something from the update repo being outdated, but disabling it didn’t change anything.

Help much appreciated, H.

Somehow, the problem seems to have solved itself. It suddenly started working. My guess is that I first had my hostname misconfigured, that this confused the DNS server, and that it took a while for it to refresh once I fixed my hostname.

Could also be the repository was heavily used or had a temporary glitch…
Does happen sometimes.


I had the same problem yesterday. All the repositories from download.opensuse.org where out or very slow. Loads of time outs. Seems to be ok today. Just a glitch I would say.