YaST webpin fix

For those that can’t wait and don’t mind some editing, here’s a webpin
fix for 11.2

sudo rpm -Uhv webpin-1.2.0-2.1.noarch.rpm

The following edit info is on the user mailing list however I modified
the version either manually edit or copy/save and patch it.

The file to edit is /usr/lib/python2.6/site-packages/webpin/const.py
Patch details here: http://pastebin.com/f5727aa03

You will need to use kdesu kate(kwrite?), gnomesu gedit or sudo when
editing the file.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 1 day 3:25, 1 user, load average: 0.15, 0.06, 0.01
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

i’m sure there is something about this that i’m not aware of, but what makes this different than the yast2 webpin package that is in the 11.2 oss repo?

seems to work okay and is v2.8something…

what am i missing about this?

Yes, you are correct, my bad!
I made an assumption that it affected the YaST one as well :frowning: because
the last few times I tried it it failed, but look like the site got
fixed so that’s now working.

I’m using it from the CLI in association with scout, but they have
still not fixed the site webpin properly sometime in the next few
days :frowning:

For example;

malcolml@linux-sisy:~> scout webpin -l
Available repositories:
suse111 - openSUSE 11.1
* http://download.opensuse.org/distribution/11.1/repo/oss/
suse110 - openSUSE 11.0
* http://download.opensuse.org/distribution/11.0/repo/oss/
suse102 - openSUSE 10.2
* http://download.opensuse.org/distribution/10.2/repo/oss/
suse103 - openSUSE 10.3
* http://download.opensuse.org/distribution/10.3/repo/oss/
factory - openSUSE Factory
* http://download.opensuse.org/factory/repo/oss/

and searching

malcolml@linux-sisy:~> scout webpin zim
package | version | arch   | repository
zim     | 0.28    | noarch |
zimg    | 5.0.0   | i586   |

It should show 11.2 repositories and versions, so just need to

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 12:38, 3 users, load average: 0.39, 0.71, 0.72
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18