Yast wants to update a package that is not installed (Postgresql)

I recently updated from Opensuse 12.1 to 12.2. No problems.
Was hoping that Postgresql 9.2 would be part of the package but as luck would have it, 9.2 came out a few days after Opensuse 12.2 so it is not part of the 12.2 ensemble and will not be upgraded until the next release of Opensuse.
So I uninstalled Postgresql 9.1 and installed Postgresql 9.2 from source. No problems, the databases restored correctly and now all is well in Postgresql 9.2.
Now today, my system tells me that there is an update for Postgresql 9.1 and insists on installing it.
How do I tell the updater that I don’t need any updates from the repo? Postgresql 9.1 is not installed so I can’t lock it.
Is this a bug or might there be a remedy that would tell the updater to forget about Postgresql?

Am 14.09.2012 14:36, schrieb colbec:
> Postgresql 9.1 is not installed so I can’t lock it.
You can taboo a not installed package.


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Ah yes, thanks for that. I had locked it but the update remained in effect, so I thought that maybe it was not locked or was being ignored.
I allowed the update and it seemed to load an update for underlying libraries. I think what is happening here is that there are some peripheral support apps for dovecot, etc., which use Postgresql. Uninstalling Postgresql does not uninstall or disable these peripherals and locking Postgresql does not lock them either, so I have now locked down these extra Postgresql-related items in Yast. We’ll see.

On 2012-09-14 15:06, colbec wrote:

> I allowed the update and it seemed to load an update for underlying
> libraries. I think what is happening here is that there are some
> peripheral support apps for dovecot, etc., which use Postgresql.
> Uninstalling Postgresql does not uninstall or disable these peripherals
> and locking Postgresql does not lock them either, so I have now locked
> down these extra Postgresql-related items in Yast. We’ll see.

I think you should allow the updates, because you do in fact have those auxiliary packages
installed. Actually, you should also compile those packages against the version of postgres you
have.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Right. Just to expand on the enunciation of this issue a bit more…
The packages are for dovecot, libpq and libecpg. Dovecot can use the lib for authentication (I believe), but I’m not using it.
libpq and libecpg are C libraries. They appeared to be made by the contrib section, my build has them.
So I dumped the Yast installed versions, keeping the new ones.
Of course things may be there but in odd places.
For example, I had to tell Python where to find pg_config when installing the psycopg2 package,
and once that was installed put a symbolic link into /usr/lib64 pointing at libpq and libecpg.so.