Yast want the DVD in the drive to install/uninstall

SuSE 11.1, KDE.

When I use Yast, to install/uninstall a program it wants me to to put
the DVD in…

Error: 2:Failed to provide Package boo-0.8.2.2960-1.51. Do you want to
retry retrieval?

[openSUSE 11.1-0|cd:///?devices=/dev/sr0] Can’t provide file
‘./suse/noarch/boo-0.8.2.2960-1.51.noarch.rpm’ from repository ‘openSUSE
11.1-0’
History:

  • Failed to mount cd:///?devices=/dev/sr0 on
    /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on
    /dev/sr0)

  • Can’t provide ./suse/noarch/boo-0.8.2.2960-1.51.noarch.rpm : Media
    Exception

this came up while installing Banshee.


wgcrowder

wgcrowder’s Profile: http://forums.opensuse.org/member.php?userid=19668
View this thread: http://forums.opensuse.org/showthread.php?t=407627

wgcrowder;1943085 Wrote:
> SuSE 11.1, KDE.
>
> When I use Yast, to install/uninstall a program it wants me to to put
> the DVD in…
>
> Error: 2:Failed to provide Package boo-0.8.2.2960-1.51. Do you want to
> retry retrieval?
>
> [openSUSE 11.1-0|cd:///?devices=/dev/sr0] Can’t provide file
> ‘./suse/noarch/boo-0.8.2.2960-1.51.noarch.rpm’ from repository ‘openSUSE
> 11.1-0’
> History:
> - Failed to mount cd:///?devices=/dev/sr0 on
> /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on
> /dev/sr0)
>
> - Can’t provide ./suse/noarch/boo-0.8.2.2960-1.51.noarch.rpm : Media
> Exception
>
> this came up while installing Banshee.
The DVD repository should be enabled in Software Repositories (also
refresh it).
If you want to use the DVD repo instead the OSS, then set it’s priority
under the OSS repos priority (<99 if the OSS is 99).


http://akoskm.blogspot.com/
http://yami.googlecode.com/

Do not login directly as root - Thank you!’
(http://tinyurl.com/593e4c)

ram88’s Profile: http://forums.opensuse.org/member.php?userid=1058
View this thread: http://forums.opensuse.org/showthread.php?t=407627

wgcrowder;1943085 Wrote:
> SuSE 11.1, KDE.
>
> When I use Yast, to install/uninstall a program it wants me to to put
> the DVD in…
>
> Error: 2:Failed to provide Package boo-0.8.2.2960-1.51. Do you want to
> retry retrieval?
>
> [openSUSE 11.1-0|cd:///?devices=/dev/sr0] Can’t provide file
> ‘./suse/noarch/boo-0.8.2.2960-1.51.noarch.rpm’ from repository ‘openSUSE
> 11.1-0’
> History:
> - Failed to mount cd:///?devices=/dev/sr0 on
> /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on
> /dev/sr0)
>
> - Can’t provide ./suse/noarch/boo-0.8.2.2960-1.51.noarch.rpm : Media
> Exception
>
> this came up while installing Banshee.

I suppose you installed your openSUSE with the DVD,
so the DVD is still listed as Package-Source in the Repository
and when installing/removing Software, YaST tries to access on it.

To prevent this you can just deactivate the DVD Repository:
In YaST => Software => Software Repositories,
uncheck the Checkbox “Enabled” on the Repository “openSUSE-DVD”.


Oh my God Windows killed zwenny!

zwenny’s Profile: http://forums.opensuse.org/member.php?userid=14385
View this thread: http://forums.opensuse.org/showthread.php?t=407627