YaST User management not working

I have upgraded from OpenSuSe-13.1-32-bit with OpenSuSE-Tumbleweed-NET-i586-Snapshot from a USB stick. When I reboot, it takes an excessive time for the logon screen to appear with the correct (only) user name. It accepts the password and then after some time returns to the logon screen. However, if I boot up with the recovery version, it comes up promptly with the desktop without any password. I am able to use YaST with the correct password but “User and Group management” does nothing. It appear a module is missing from the setup. Help would be much appreciated.

Perform a clean TW install. Too much has changed. You can still preserve your partitioning, users, /home ( if on a separate partition )

Are you saying I have to “install” rather than “upgrade”?

 I started again: this time doing a full install rather than an upgrade. The result was that, on booting up the new system, pI am still unable to log in. It just waits almost 10 minutes to return the login page in spite of the correct details being given. Furthermore, I get the same result when I boot up the recovery option whereas it gave access to my system when I had previously used the upgrade version.  I have now reverted to version 13.2.     Eversince version 7.0 I have been installing (Open)SuSE with no problems. Leap is running well on my laptop but, since my PC is only 32-bit I had to try TumbleWeed i568. I appears 32-bit has been sidelined and not fully tested.
 Ccmments would be welcome.

What’s the video card involved ?
Does this happen for a newly created user ?
Do you see any error messages when hitting Esc after booting the TW install ?

The video card is Integrated Intel Extreme Graphics 2. Unable to create a new user as as unable to login to system now but I did create a new one during install but made no difference. No error messagrs seen.

Hu Knurpht

I’m afraid I misled you. My graphics card is: GeForce FX 5200 (0x0322).
Does this have a bearing on 32-bit Tumbleweed constantly returning the login page even though I have logged in?
The page in plain black and white.

Just in case this is helpful:

Open a VT eg Ctrl+Alt+F2, then login as user. Edit ~/.config/kwinrc with a CLI editor (eg nano) so that ‘OpenGLIsUnsafe=false’ becomes ‘OpenGLIsUnsafe=true’. Save when done. Switch back to VT7, and try logging in to a graphical session again. As nrickert suggested changing the rendering backend to ‘XRender’ might also be beneficial.

No offense …
But the title does not reflect the topic of the post

Unfortunately all too common…

Not entirely true V_idocq because, when I first used the upgrade option, I was unable to login but I found I was able to access my system via the recovery option without logging in. I then found via YaST the user Management did not work (other functions did). Now that I have used the full upgrade I have no sccess at all. All I know is that my password is not recognised so the login page continuously recycles.
In reply to deano_ferrari I will try your suggestion. I am currently on 13.2 again but will use th TW Upgrade again.

She does not want to be my offensehttps://www.cantineduepalme.it/wp-content/uploads/2017/07/cincin.jpg
But posts besides helping those who do them can also serve others with a similar problem.
The title is “YaST User management not working” and in the post where do you talk about this?

Thank you deano_ferrari. I have followed you edit I was then able to login as root, type startx and the root kde desktop came up. Yast/user now works so I set up a new user but on rebooting I had the same problem,PROBLEM SOLVED I believe. Definitely an installation problem The opensuse download repository is/was down resulting in no systemd. I’ll raise a separate thread to enquire how to load systemd plus dependencies from another source.

This doesn’t make sense to me. If systemd was missing you wouldn’t be able to boot. Have you tried updating from a VT? (Assuming you have network connectivity.)

Of course you are right about systemd. My mistake was to use a mini usb stick to set up my system, installing directly while there was possibly an outage if some of the depositories. Several times when refreshing via Yast I have found the server unavailable. I have tried downloading the full iso file but when checking with sha256sum I get 15 files wrongly formatted. I have tried to correct with rsync but k3b did not like the result. I will continue to try with my laptop Leap system.

After reinstalling several times I remembered your query about my video card. This led me to adding the Nvidia repository (for GeForce FX5200), reinstalling/adding several Nvidia modules and rebooting I had requested automatic boot and the desktop came up in 2.25 minutes. Rather long but I’ve got there!:wink:

I am now returning to the title of this thread.
After getting the desktop I tried to add another user… Yast/User and Group Management installs as far as "Read Users and Groups and then aborts. I note that Yast/Services Manager shows all systemd services are disabled. When I try to enable any of them it advises (can’t do) as no install section in the description. Any suggestions?

Examine /var/log/YaST2/y2log for relevant errors. Open a terminal and run

sudo tail -f /var/log/YaST2/y2log

then open YaST User and Group Management. Observe/capture the output, and post the output here for others to review.

I note that Yast/Services Manager shows all systemd services are disabled. When I try to enable any of them it advises (can’t do) as no install section in the description. Any suggestions?

These are activated as dependencies by other systemd units as required, so there is no need to try to enable these directly. What are you specifically trying to achieve here?

Thank you. Immediately after booting up I ran Yast/Users… and then examined y2log via VT. The result is in 1stScreen.jpg. I then repeated yast.Users… via VT and the new record for y2log is in 2ndScreen.jpeg.
Thanks for advice on system. I though it had a bearing on my login problem - now solved.

Please advise how to send the two images. My reply wants a URL. I want to just attach the image files.

Can you not copy the log to a memory stick and post here as text? That’s generally preferred to images, especially when searching through output is required. For lengthy output, consider uploading to https://susepaste.org/ and post the link that it generates here.