Yast update problem...

Hi there…

I m comming to you one more time because im still a newbie!!!

And i know that i shouldnt have done something without knowing but… Too late!

I have performed an update on yast… ( sorry but i dont remenber witch paquages i ve installed!(of course it would have been too easy!!!)

And now, I have an error message when i run yast:

YaST got signal 11 at YCP file PackagesUI.ycp:232

/sbin/yast2: line 437:  3981 Erreur de segmentation  $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

and i cant use the yast graphic thing anymore, since that update!

i ve done a zypper up and a zypper dup with the terminal, thinking that it will save me from my stupidity,but as you can see my thread… No luck!!

So if anybody as an idea, ill take it with pleasure!!!

Thank you very much for trying, reading or even laughing!! :wink:

Hi and welcome!
First, this isn’t your stupidity - you performed a regular update…
Start the YaST interface in terminal:

sudo /sbin/yast

navigate to Software Management (with TAB). Now into the search field type yast and hit Enter. With the key combination ALT + T you can select the Action menu (bottom right). Here select the All listed pacakges > Update All Unconditionally.
Hope that helps, good luck.

Thank you for your advice, but unfortunatly it didnt solve the problem!
i ve also tried to update gnome2.24 to 2.26
but still…
If you have any other idea, ill take it…

thank you for your time

There we go, you had it…

But the goal was to downgrade yast!! (the update one seems to be in conflict w/h QT4.5)

So i did the process that you told me
but after disabling all the repository exept the original one!!(openSUSE-11.1-Oss)

In a terminal :
under root
zypper sl (in order to know your repo code)
zypper mr -d [the repo code you want to disable]

thank you Ram88

and long life to opensuse

Ow, then it’s another story. :slight_smile:
You haven’t mentioned that you added any repository to software repositories - exluding the official update repo.
Remember, these repositories may contain buggy software!
Good luck and have a lot of fun! :wink: