YaST update crashed my system - Pls Help

Leap 42.3, KDE. An hour ago performed a weekly update w/ YaST. I don’t know how to retrieve a list of what I updated so that I can post it here, the y2log file is huge. I have only the 4 main & update repositories active.

When I boot, KDE does not start. I get the chevron shaped symbol with the 3 moving dots but after that finishes I don’t get the familiar gear symbol with a K in the middle. I am left with a blank screen & mouse cursor that moves but nothing else. I don’t know what I am supposed to do to rollback, I chose a snapshot from last week and am now booted to a readonly system.

I have a list of Pre & Post snapshots from last week that contain

yast sw_single

I realize the info I have presented is not the best, frankly I just freaked out that this happened and I don’t know how to recover.
I’d like to know how to proceed to get myself with a working system.

When you reach the cursor on the black screen type CTRL + ALT + F2 enter the console, login then become Root by typing

su -
> sending > and zypper dup throws when it finishes> reboot
If it does not work, you need more information about your system

You should normally not use “zypper dup”, unless you want to upgrade to a new openSUSE version (or are using Tumbleweed).

If it does not work, you need more information about your system

Actually, more information is essential before suggesting to run “zypper dup”, because that could break the system completely.

In particular, what repos are active:

zypper lr -d

You might be able to open krunner with Alt+F2 or Alt+Space in the broken KDE/Plasma session and run konsole or xterm.
You could try to run “plasmashell” there and see if it starts (it might give an error message that could be helpful).

You should also be able to get back to the login screen by pressing Ctrl+Alt+Backspace twice and then login to IceWM e.g.

Also, I would try to boot the previous kernel, does that work?

There haven’t been any updates to KDE in 42.3 that could cause such a problem… More likely a problem on a lower level.

PS: you can get a list of installed packages (sorted by time of installation) by running “rpm -qa --last” (preferably pipe the output through less or tail, e.g. "rpm -qa --last
Or look at /var/log/zypp/history .

Translation error

Thank you for these suggestions, and also to V_idocq for offering help. When this problem came up, the best I could think of at the time was rollback w/ snapper (and I still have to learn the proper way to do that). When I tried to do that I found myself booted to a read-only system. I had already tried opening a new tty but it failed to open, I don’t know if that had anything to do with how I had booted. The above commands are very helpful and I’ve saved them. Some I had forgotten about.

As stated, none of the 13 pkg updates I installed involved KDE and thus maybe there is a lower level problem. With the machine sitting off for 7 hours it booted up correctly :), even tho it would not do that through several tries last night. Maybe a hardware problem, time will tell…