Yast Unable To See Free Space On Drive With Windows 7 (Can't Install)

I have searched for solutions, but most of what I have seen have to do with UEFI issues. My laptop BIOS is in “Legacy” mode.

Dell Latitude E6440
320 GB Hard Drive

Windows 7 installed - and I want to make it dual bootable to both Windows and OpenSuse.

I’ve done dual boot installations before but it has been some years.

I have shrunk the partition using Windows Disk Manager.

When I try to install OpenSuSe (both Leap 42.2 and 42.3), I get to the partition screen, but YaSt does not see the unallocated hard drive space. It does see the Windows file system, and I get an error that there is no permissions to change anything. I cannot remember the exact error message, but basically nothing can be done. Even if I wanted to install over Windows, I could not do it.

I have read some things about issues with drives that are partitioned as MBR or GPT - but I do not know if that is the problem.

I have booted the laptop with a Knoppix Live DVD, and have run fdisk -l:

Device Boot Start End Sectors Size ID Type
/dev/sda1 * 2048 206847 204800 100M 7 HPFS/NTFS/exFAT
/dev/sda2 206848 625137663 624930816 298G 7 HPFS/NTFS/exFAT

Have no clue what to try or do next. Any advice would be greatly appreciated.

I should also point out that I am open to reinstalling Windows - this is a “new to me” laptop with nothing of any consequence on it that I need to back up or save. I am not sure if that is necessary, however.

Just in case, I have downloaded and burned a live gparted DVD - but am not sure what I would do, if anything, with that.

As you did not post all of the fdisk -l output, we can not see if there is free space either. We see only the two partitions that occupy together from 2048 - 625137663. But as we do not know how large the disk is, the free space you mention is not to be seen.

Besides what Henk posted above,
You can use Gparted Live to just inspect and verify your disk layout… without changing anything.


Sorry for the confusion - what I did was:

  1. Shrunk the 2nd Windows partition in half using Windows diskmanager.
  2. Attempted to install OpenSuse. It did not see the free space.
  3. Tried several attempts to install OpenSuse but couldn’t past the partitioning screen.
  4. I then undid the first shrinking.
  5. Tried to find solutions to no avail.
  6. Then I did the fdisk -l (after I had returned the partition to the original size). I had read some things which I did not totally understand about MBR and GPT partitions and was trying to figure out if that was the problem, but it “seems” to be it’s MBR - it’s labelled as dos.

I know with previous installations of older Windows and older OpenSuse, I had never had any problems with dual-boot installs and never had to shrink the Windows partition to create unallocated space.

When I have a moment, later this evening hopefully, I will go back and again shrink the Windows partition and then provide another fdisk -l command output.

We are not that much interested in what you did to come to the present situation, but we are interested in what the present situation is. Thus we need the complete output of e.g.

fdisk -l

or another tool like thiss (gdisk or whatever, but NO Windows tool).

You only gave us a few lines and not the complete output.
Also please put that output between CODE tags. You get the CODE tags by clicking on the # button in the tool bar of the post editor.