Yast, Tumbleweed, language issues

I am in Québec Canada. I often write in French, and thus I have a Quebec French keyboard.

BUT I installed the ENGLISH version of Tumbleweed, And did not specify French as the second language, other than the keyboard layout (ca)

My menus are being presented half and half, many are in French, (eg Yast), and the default, which is what I want to be, English.

The issue includes the virtual terminal and other software.

There is a coding bug that is looking at the keyboard for the user interface language, the correct response should be to look at the desired Display language which is English

Being Bilingual, it does not bother me, as I am fluent in both English and French, its just some coding errors that retrieved the wrong language texts.

What to do? Region setting is English.

Are you talking about what the desktop uses as language? Then telling which desktop environment you use might be interesting.

What’s the content of /etc/sysconfig/locale and /etc/locale.conf?
What does “localectl” say?

The used keyboard layout should not have any influence on the language.
But the installer will set the system language to what you choose during installation of course, and IIRC it also changes the language if you choose a different keyboard layout on the first screen.
And your desktop’s language settings may only apply when you are actually logged in to that desktop (in particular not on a virtual konsole), and YaST runs as a different user (root) anyway.

I am using English, (Candian English) which is the same as British English (more or less). The keyboard is a PC195 Canadian French Layout

localectl status
localectl status
System Locale: LANG=en_CA.UTF-8
VC Keymap: cf
X11 Layout: ca,ca
X11 Variant: ,eng
X11 Options: grp:menu_toggle

There is no /etc/sysconfig/locale
The Yast details are in French, while most menus are in English, which is what I want to have.

cat /etc/locale.conf


Dolphin is in English, etc.

Hm, I’m not sure that’s really how it is supposed to be, but that shouldn’t have an influence on the language used as I wrote.

There is no /etc/sysconfig/locale

Ok, it probably has been removed in Tumbleweed meanwhile, in facor of /etc/locale.conf and others.

The Yast details are in French, while most menus are in English, which is what I want to have.

Well, YaST runs as root, as mentioned, so it uses root’s settings that may differ.

/etc/locale.conf seems to be set “correctly” (to en_CA), but what does “locale” say?
Run it both as user and root.

Also, what is $LANGUAGE set to?


As far as I can tell, region/language and any other KDE language setting is/are correct. And by the way, my second Tumbleweed (gnome version) on a second drive on this same computer is fine. Its only KDE’s Yast, and some virtual terminal messages. (As an aside, this is where KDE makes me feel at home. Here in Quebec, in the street or at restaurants, we mix both French and English together in the same sentence. The purists hate it but we always say “Bonjour-HI”

Back to KDE. When I launched the installation, it was done in English. I did stipulate the CA keyboard layout.
When I did the initial installation, I indicated CA as the keyboard, I did not specify language until post installation, where I setup Canadian region (for metric, and date, time, currency formatting).
I will more than likely redo the installation, on this desktop as my laptop can serve me well while the reinstallation takes place.

And what are these settings exactly?

Something seems to be off otherwise you wouldn’t have the problem in the first place…

As I wrote already, YaST runs as root, so it might not use the user’s KDE region/language settings.

And I’m not sure what you mean exactly with “virtual terminal”. If you are not logged into KDE, the KDE region/language settings won’t be applied at all. If you are running a terminal emulator (e.g. xterm, konsole), they will be used though.
In the latter case, either the settings are not correct, or the affected applications get confused by your settings.

So again, please post the output of “locale” and the content of the $LANGUAGE environment variable both as user and root, and preferably also from your other system where it works as comparison.

Lets close this issue. I took yesterday’s fresh install as an upgrade. After reboot, all of Yast headings in the GUI were in French, but the terminal mode stuff was in English. I suspect that some plasma setting was the problem.
I write, was the problem, as I have wiped /, swap, btrfs and bios boot and will do a clean installation using the USA keyboard layout. Post installation I will add the Canadian French keyboard layout.

Post install, I will add the second language for the dictionaries and spelling checker.

Thanks for trying to assist with searching out the gremlin, but since I wiped the partitions mentioned, it’s a fresh install.

Yes, that’s what I am suspecting as well (right from the start actually :wink: ).
That’s why I asked for the output of the “locale” command and “echo $LANGUAGE”, which you still didn’t provide…

I somehow assume that you will run into the same problem if you add a second language in KDE’s settings though. :wink:

Btw, we do not “close” threads here normally. If you want to express that it’s solved for you, please add “(solved)” or similar to the subject when replying.

What I discovered is a bug?? with Thunderbird when the second language specified is French. Here is what I discovered

The main language during the installation was English, with French as the second language.

When I created the administrator, within $HOME/leslie some menus appeared in French and French it was.
Yast was in English until I clicked on a sub-category, The sub-category opened up in French.
I did not discover anywhere, a menu provision within Yast or other to specify the interface language for a user.

An easy fix was, as root, rename the $HOME folder, and cp /etc/skel to $HOME
also chown Leslie $HOME -R

Thereafter, moving over a few subdirectories (Dropbox, music, project, documents, Downloads etc) and my new Tumbleweed is now unilingual

Somewhere in the depths of $HOME is a user setting to indicate the user’s preference for a second language. I know not where to find that setting.
Nevertheless. My recreation of $HOME solved my problem.

Hard to say without knowing your exact settings and the output of the commands I asked.

Somewhere in the depths of $HOME is a user setting to indicate the user’s preference for a second language. I know not where to find that setting.

If you add a second language in KDE/Plasma’s settings, it will be saved to ~/.config/plasma-localerc and ~/.config/plasma-locale-settings.sh, the latter is actually a shell script that’s run when you log into Plasma and sets the corresponding environment variables.