Yast Software manager freezes

I just installed OpenSuse 11.1, and upgraded from 10.3 . The package manager was a little wonky. Everytime I tried to update, it froze in the middle. Using command-line zypper as root froze also, during downloading of certain packages (libvzio, for example).

So, I decided to clean out the cache.
zypper clean -a

That was a bad idea. Now, whenever I open the software manager, it freezes, saying “loading package manager”.

Same with zypper.
linux:/home/scott # zypper -v update
Verbosity: 1
Initializing Target

Any idea?


boot to runlevel 3
login as user then go su

rpmdb --rebuilddb

zypper ref

zypper dup

a newly installed suse-11.1 updated with yast finds no more updates.

but running a zypper dup wants to install 115 packages of updates!!!

Give us

zypper lr

“zypper ref” worked. But “zypper dup” hangs. Same with “zypper up” and “lu” and pretty much every other command.

zypper lr works.

These are the enabled repositories:
openSUSE 11.1-0


What do you get from

zypper up -t yast2

linux:/home/scott # zypper up -t yast2
Unknown package type ‘yast2’.

Ok try

zypper in -f yast2

you could try add in the * at the end to do all yast2 (the f = force)

zypper in -f yast2*

linux:/home/scott # zypper -v in -f yast2
Verbosity: 1
Non-option program arguments: ‘yast2’
Initializing Target

Same with yast2*

Is there a directory or something I can delete? I remember last time I had problems with zypper (in like suse 10.2 or something) I had to delete /var/lib/zypper/ or something? Somehow clear the cache? Can’t quite remember how I fixed that.

In a terminal do

rpm -qi yast2

what do you get?

You could try, booting to runlevel3
login and go su
then run


It should run a basic form of yast for you so you can re-install all yast and do updates

(runlevel3, can be reached from default boot, clear all boot arguments and just type: 3 )
(then hit enter)

Name : yast2 Relocations: /usr
Version : 2.17.54 Vendor: openSUSE
Release : 1.1 Build Date: Wed 03 Dec 2008 09:46:26 AM MST
Install Date: Sat 20 Dec 2008 10:52:31 AM MST Build Host: build04
Group : System/YaST Source RPM: yast2-2.17.54-1.1.src.rpm
Size : 3514451 License: GPL v2 or later
Signature : RSA/8, Wed 03 Dec 2008 09:48:24 AM MST, Key ID b88b2fd43dbdc284
Packager : Submitting Bug Reports - openSUSE
Summary : YaST2 - Main Package
Description :
This package contains scripts and data needed for SuSE Linux
installation with YaST2

Cool I’ll try re-installing in runlevel 3, thanks!

It freezes in runlevel 3 as well.

Sorry it took so long to reply, it’s been a while since I had time to boot to runlevel 3 without causing problems to my services.

The fact that you say at the beginning, you updated from 10.3 - This is probably compounding the issue.

It is generally not considered wise and neither would I recommend it - A Upgrade from 10.3 - 11.1

Fresh install only.

Keep /home if you must: But I would just backup docs etc and format that too.

The only other option I can offer is boot from the dvd use repair. You want to repair the Installed Packages. But you need to select the expert option and then choose the packages section for repair.
You need to LOCK/Do Not Modify every package. Just re-install all yast and zypper.

Yeah I agree upgrading from 10.3 was a bad idea… it’s really too bad that doesn’t work, that makes upgrading a serious proposition rather than an afternoon activity.

It turns out that the freezing problem was removed when I removed some of the repositories in Add/Remove repositories. I’m not quite sure which one, but it’s entirely possible it was the DVD source. So maybe it was a hardware problem after all. Anyways, all resolved with no re-install needed.


Add another with problems getting updates same as OP. This WAS a fresh install of 11.1 from the retail ($$) DVD kit. Every time I try to do any updates, no can do. I am registered. I have a call in to support. If/when I get this resolved, I’ll post here.

After trying update again and having it fail again, here’s some screen output:

There was an error in the repository initialization.
‘repo-update’: |] Valid metadata not found at specified URL(s)

  • Unknown error reading from Index of /update/11.1
  • SKIP request: User-requested skipping of a file
  • Timeout exceed

From the looks of the above message I wonder if all is well with the 11.1 update server.

I then tried getting to the update URLs with FireFox and was able to get to all of them OK, but not with the v11.1 update stuff.

Still waiting for a call back from support.

Just got a call back from Novell support. They are stumped as to why software updater is not working. They asked me to check this and that (rpm,zypper,yast ,etc) as mentioned in this thread. All looked OK except it doesn’t work. :wink: Once again I have the Novell purchased retail kit DVD, so I’m entitled to support.

They said they’d get with the developer/s and get back to me tomorrow. I mentioned that this issue is being posted on these forums.

Another message received when I try tp update. Wonder if anyone else has seen this one:

Valid metadata not found at specified URLs:


I’m getting very similar problems. With my fresh 11.1 installation, the Package Manager hangs when trying to retrieve metadata for the debug repository and won’t go any further.

If it were me, I would delete everything in the repo’s and start again. But I’m guessing you tried that?