Yast Software Management Errors OpenSUS 11.3

Hi need help, have trawled many sites and tried variuos things to no avail.

When loading SoftwareManagement from YAST it closes down and gives the error.

terminate called after throwing an instance of ‘zypp::media::MediaFileNotFoundException’
what(): Media Exception
YaST got signal 6 at YCP file /usr/share/YaST2/clients/sw_single.ycp:294
/sbin/yast2: line 399: 10062 Aborted $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

I have tried removing and re adding all repositories and also zypper dup but to no avail.

I currently have
| Alias | Name | Enabled | Refresh | URI
1 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | No | No | cd:///?devices=/dev/sr0
2 | repo-debug | openSUSE-11.3-Debug | Yes | Yes | Index of /debug/distribution/11.3/repo/oss
3 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | Index of /distribution/11.3/repo/non-oss
4 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | Index of /distribution/11.3/repo/oss
5 | repo-source | openSUSE-11.3-Source | Yes | Yes | Index of /source/distribution/11.3/repo/oss
6 | repo-update | openSUSE-11.3-Update | Yes | Yes | Index of /update/11.3

But any attempt to update these gives error similar to
Retrieving repository ‘openSUSE-11.3-Debug’ metadata ]terminate called after throwing an instance of ‘zypp::media::MediaFileNotFoundException’
what(): Media Exception

http access is OK through Konquror (Firefox is also crashing but thats another story).

Can anyone help please, please note I am a Linux novice but have Windows experience.

Did you check the install media like this - before install?

Yes install media checked out OK.
It should be noted this was an update from version 11.2 via the DVD and not a clean install.

Try as su

zypper clean --all

Tried but no change.

Any reason you didn’t do the clean install,seeing that it always works better?

Just did not want to have to reinstall applications that already worked on 11.2. Looks like it may be the only way out though.:’(

It’s a lot quicker usually.
If all your applications are in the repos then it should be fairly painless.

No such luck