Yast problem after online update


(running openSUSE 11.0, KDE 4.2)

After online update, Yast started to crash. Yast panel opens, but when I select anything inside it (like software management, boot loader etc.) it crashes and gives error:

YaST got signal 11 at YCP file /usr/share/YaST2/clients/inst_packages.ycp:36
/sbin/yast2: line 421: 4378 Segmentation fault $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

How do I resolve this?

  • remove /var/cache/zypp/zypp.db and /var/cache/zypp/zypp.db-journal

sudo rpmdb --rebuilddb

  • then run ‘zypper refresh’

try yast again.

If necessary run it from CLI to re-install all yast packages

Are you tried to update unconditionally your YaST packages also with yast but from the CLI?

I’m getting the same error message as beli0135. I submitted a bug report to Novell’s bugzilla but haven’t heard anything yet.

I tried deleting the zypp files mentioned above and reinstalling the YaST packages but that didn’t fix the problem.

Actually several days ago I deleted some zypp files following some instructions I found on the mailing lists. The files listed above sounded like the ones I deleted, but after checking, I discovered that I don’t have these files.

I have /var/cache/zypp, but there’s no zypp files within this directory.

This directory is the local cache for zypper. It doesn’t cause anything if you delete files from them. Next time if your run

zypper refresh

zypper fills this cache with repo data.

I still haven’t had time to fix as you suggested, but last night, I uninstalled Yast completely, then reinstalled it. I get the same error in GUI, but when run from console it works.
Seems that some library that handles gui is broken.


i have the some problem. I used at first openSUSE11.1 and now i install SUSE 11.0 and it is the some problem. >:(

has anyone a workaround or any help ?

thanxs a lot


When I find it, I will post here.

Seems that some package of yast was updated and it is broken.
For now, use yast from console when you need to fix something

Check it out: Problem with Yast2 and KDE4 openSUSE 11.0 - Page 2 - openSUSE Forums

Yes, I figured that downgrading yast will resolve things. I save that for the times when I will have the time to mess with it.
Since it is on home laptop, it will take a while. Too drained from work to play with it at nights.