YAST PRINTER RESTSRT necessary after boot

Since 42.2 printer don’t work right away,

I need always to start yast printer module and then it displays CUPS restart and my printers are back.

Where do I get the normal behaviour back

Check cups.service status after boot

sudo systemctl status cups.service

**#** systemctl status cups.service
● cups.service - CUPS Printing Service
   Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: inactive (dead)

Let’s have a look at the cups.service configuration

cat /usr/lib/systemd/system/cups.service

For a more indepth look at behind the scenes perhaps review these as well

sudo journalctl -u cups.service
sudo journalctl -b |grep cups

cat /usr/lib/systemd/system/cups.service
[Unit]
Description=CUPS Printing Service
After=network.target

[Service]
ExecStart=/usr/sbin/cupsd -f

[Install]
WantedBy=multi-user.target


journalctl -u cups.service
-- Logs begin at Do 2015-01-15 14:00:49 HKT, end at Mi 2016-11-30 14:00:39 HKT. --
Mär 22 16:27:29 linux-wcxd systemd[1]: Stopping CUPS Printing Service...
Mär 22 16:27:29 linux-wcxd systemd[1]: Stopped CUPS Printing Service.
**-- Reboot --**
Mär 23 09:13:08 linux-wcxd systemd[1]: Starting CUPS Printing Service...
Mär 23 09:13:08 linux-wcxd systemd[1]: Started CUPS Printing Service.
Mär 23 09:16:28 linux-wcxd systemd[1]: Stopping CUPS Printing Service...
Mär 23 09:16:29 linux-wcxd systemd[1]: Stopped CUPS Printing Service.
**-- Reboot --**
Mär 23 09:17:50 linux-wcxd systemd[1]: Starting CUPS Printing Service...
Mär 23 09:17:50 linux-wcxd systemd[1]: Started CUPS Printing Service.
**-- Reboot --**
Mär 23 17:05:53 linux-wcxd systemd[1]: Starting CUPS Printing Service...
Mär 23 17:05:53 linux-wcxd systemd[1]: Started CUPS Printing Service.
Mär 23 17:12:58 linux-wcxd systemd[1]: Stopping CUPS Printing Service...
Mär 23 17:12:58 linux-wcxd systemd[1]: Stopped CUPS Printing Service.
**-- Reboot --**
Mär 24 14:28:15 linux-wcxd systemd[1]: Starting CUPS Printing Service...
Mär 24 14:28:15 linux-wcxd systemd[1]: Started CUPS Printing Service.
Mär 24 14:28:43 linux-wcxd systemd[1]: Stopping CUPS Printing Service...
Mär 24 14:28:43 linux-wcxd systemd[1]: Stopped CUPS Printing Service.
**-- Reboot --**
Mär 24 14:30:01 linux-wcxd systemd[1]: Starting CUPS Printing Service...
Mär 24 14:30:01 linux-wcxd systemd[1]: Started CUPS Printing Service.
Mär 24 14:30:22 linux-wcxd systemd[1]: Stopping CUPS Printing Service...
Mär 24 14:30:22 linux-wcxd systemd[1]: Stopped CUPS Printing Service.
**-- Reboot --**
Mär 24 14:31:34 linux-wcxd systemd[1]: Starting CUPS Printing Service...                                                                                                           
Mär 24 14:31:34 linux-wcxd systemd[1]: Started CUPS Printing Service.                                                                                                              
Mär 24 14:44:59 linux-wcxd systemd[1]: Stopping CUPS Printing Service...
Mär 24 14:44:59 linux-wcxd systemd[1]: Stopped CUPS Printing Service.
**-- Reboot --**
Mär 24 14:45:57 linux-wcxd systemd[1]: Starting CUPS Printing Service...
Mär 24 14:45:57 linux-wcxd systemd[1]: Started CUPS Printing Service.
Mär 24 16:40:58 linux-wcxd systemd[1]: Stopping CUPS Printing Service...
Mär 24 16:40:58 linux-wcxd systemd[1]: Stopped CUPS Printing Service.
**-- Reboot --**
Mär 25 13:50:37 linux-wcxd systemd[1]: Starting CUPS Printing Service...
Mär 25 13:50:37 linux-wcxd systemd[1]: Started CUPS Printing Service.
Mär 25 13:53:02 linux-wcxd systemd[1]: Stopping CUPS Printing Service...
Mär 25 13:53:02 linux-wcxd systemd[1]: Stopped CUPS Printing Service.
**-- Reboot --**


journalctl -b |grep cups

no output

Okay, this reminds me of a similar thread where similar CUPS behaviour was being observed.

Execute these commands and report back…

systemctl status cups.socket
find /etc/systemd/system/ -iname "cups*"

systemctl status cups.socket
● cups.socket
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)


 find /etc/systemd/system/ -iname "cups*"
/etc/systemd/system/printer.target.wants/cups.service
/etc/systemd/system/sockets.target.wants/cups.socket
/etc/systemd/system/multi-user.target.wants/cups.path

Looks like you have socket activation configured for CUPS. Some users prefer to have cupsd running permanently (rather than on demand). If desired, you could remove those files then

systemctl daemon-reload
systemctl enable cups

Reboot and check that cups.service is still active after booting complete.

FWIW, your experience is similar to this archlinux thread

https://bbs.archlinux.org/viewtopic.php?id=216216

deano_ferrari Thank you for your help!

After your steps I came to realise I should use brain 0.1 and check services.

YAST2 -> SYSTEM -> SERVICES ->  CUPS : start 

does the trick. :shame:

Yes, but that can be done with systemd command as well

systemctl start cups

check that following a reboot cupsd is still active. It does look like socket activation (CUPS on demand) is at play here (which works for most users anyway if properly configured). Let us know if you need to investigate anything further.

I wrote the last post after a reboot, to check, if it will work and it does. :slight_smile:


systemctl start cups

I did not check use from a terminal.

As it is working now, I will go file some bugs on LO

Ok, good to know. :slight_smile: