Yast oxygen icons missing

I don’t have anymore the Oxygen icons in Yast. I think it happened when I removed an obsolete branding package that came with the original installation image and no longer was available in the current repositories.
Is there any way to bring them back?

I currently have installed the following package, but it does not seem to make any difference:

yast2-theme-oxygen-4.1.8-1.1.noarch

Thank you

https://lh3.googleusercontent.com/As-Vu7WBJY7uSux7_67qCEksvPnv9eUYktoAApCJ_PvA6tQkweLu0tA-JyVHqf6y7DUnXF3GNehmDIhHhTKgV6DLDY_-hcrKU9KPcShpIgjrU_mryTPcDpUe71CM39_XKAj5rXPSurReZ2RjfgZxPfppJ3AszL5SB7LUOyuruGOHNpUnmPmqWMlfXNYiLPFkCg-08FJEVnnIiQujQwznsmLs1M63g-Z-_9Hs_y46N35861I83T5DCws2cSjACGKUL3fsQ81_5Smv-P1-JF-xU6Up8aXZSmCfj5vGo-Wm37v6sknZXXw2I4ILV_pkP9A6-ZyOyJqToBFqls1JHMtS2KCFfsjZdPSQF8M1jVIWvZiA3yZVpX2l6_6PPVYAACwbydhSqpI1LOsqzS54ZeQUlp1CrUdY-TgaysMLeorVOdauY4dfJT-tELxlJmhQgAcXidtbb5uufTtv_k4ObgbWGrNuCPLxHSrg2i4TW5XkcDYkq73kp2hgfEcWaF9Uvbh1FCGjXs0DSyyOFcYCvJKe6rElxW6XSDJZS5iDz-qCITnm6AkebdnHTfdVlNRTIQrzZe0nW72CQM0VVhUAtYX2t6_mLhdyb16mf17_4D_R6C1OjClfOrjnbBC7BHqPkGFVQNr0dOnzd1pv6Pzfw2OJ4N260RVZLVk=w820-h535-no

On this Leap 15.0 system, the YaST Oxygen icons are supplied by the “yast2-branding-openSUSE” package – the package is not listed for Tumbleweed …

The Leap 15.0 package “yast2-branding-openSUSE-Oxygen” (not listed for Tumbleweed) contains only the file ‘/usr/share/doc/packages/yast2-theme/yast2-branding-openSUSE-Oxygen.txt’ which has only one line: “This file marks the package yast2-branding-openSUSE-Oxygen to be installed.” – installation of this package results in a symbolic link to be set which cause YaST to use the Oxygen icon set …
[HR][/HR]Therefore the repair is either:

  • Install the Leap 15.0 packages and then lock them to ensure that, they are not removed and/or,
  • Raise a Tumbleweed Bug Report and (if “or”), wait …

I have looked at the package that you say “yast2-branding-openSUSE-Oxygen” and it basically makes a symlink to activate package “yast2-branding-openSUSE", which actually contains the icons:


postinstall scriptlet (using /bin/sh):
if test -L /usr/share/YaST2/theme/current/icons ; then
  rm /usr/share/YaST2/theme/current/icons
fi
ln -s /usr/share/icons/oxygen /usr/share/YaST2/theme/current/icons

I already have the oxygen icons from Tumbleweed package “yast2-theme-oxygen”, which seems equivalent to Leap 15.0 “yast2-branding-openSUSE". Unfortunately creating that symlink on my system has no effect.

BTW, I see that those Leap 15.0 packages have disappeared from Leap 15.1 too…

I have found that in this link, under “Updated YaST Branding and Icon Handling”, this change in Yast was explained, but from what they say, it should be just install the package. It really does not explain how it works and I cannot find any Yast config file dealing with this. :frowning:

https://lizards.opensuse.org/author/yast-team/

Do you have any “yast*.png” files (supplied by the “yast2-branding-openSUSE” package) in the directory tree below /usr/share/icons/oxygen/ ?

Leap 15.1 is currently in the alpha test phase – as testing proceeds the “missing” packages may well reappear due to Bug Reports written during the testing …

Yes, I have the icons. As I said, in my case they are supplied by package “yast2-theme-oxygen” instead of “yast2-branding-openSUSE”, which no longer exists.

oscar@seafire:~> ll /usr/share/icons/oxygen/
total 168
drwxr-xr-x 1 root root    100 Jun  9  2018 128x128
drwxr-xr-x 1 root root    100 Jun  9  2018 16x16
drwxr-xr-x 1 root root    100 Dec 31 09:56 22x22
drwxr-xr-x 1 root root    100 Dec 31 09:56 32x32
drwxr-xr-x 1 root root    100 Dec 31 09:56 48x48
drwxr-xr-x 1 root root    100 Dec 31 09:56 64x64
drwxr-xr-x 1 root root     84 Jan 21 10:32 base
-rw-r--r-- 1 root root 155616 Feb  2 17:20 icon-theme.cache
-rw-r--r-- 1 root root  14911 Jan  4 22:45 index.theme
drwxr-xr-x 1 root root    100 Jun  9  2018 scalable
oscar@seafire:~> find /usr/share/icons/oxygen/ -name yast\*.png |wc -l
372
oscar@seafire:~> rpm -qf /usr/share/icons/oxygen/48x48/apps/yast-dns.png 
yast2-theme-oxygen-4.1.8-1.1.noarch

A new point release (4.1.9) of yast2-theme-oxygen was submitted yesterday.
Apart from that, I can only suggest that you submit a Bug Report.

Hi dcurtisfra,

The update didn’t fix it. I will take a look in the bug reports and maybe file one as you say, but I would have preferred to understand how Yast works now in this regard and see if it is a config problem.

Thanks anyway for your time and your help.

Now I’m also confused: since forcibly reinstalling the yast2-branding-openSUSE-Oxygen package a couple of days ago, a recent patch seems to have moved the “/usr/share/YaST2/theme/current/icons” link back to “/usr/share/icons/hicolor/” …Forcibly re-installing yast2-branding-openSUSE-Oxygen moved the link back to “/usr/share/icons/oxygen/”.
Really weird is, even with the link pointing to “/usr/share/icons/hicolor/”, the YaST Control Centre was using the Oxygen icons …

My thoughts are:

  • My KDE Desktop is using the Oxygen Theme.
  • There’s nothing I can see in /etc/sysconfig/yast2 which could be influencing the behaviour I’m seeing:

“WANTED_SHELL” and “WANTED_GUI” are both set to “auto” …

Which KDE Desktop theme are you using?
Are you using the default sysconfig YaST settings?

OK, that is weird, yes. :o

I am using Desktop Theme “Breeze Dark” and Icon Theme “Breeze” in KDE. Tried changing both to Oxygen but there is no change in Yast, not even restarting the session.

Both WANTED_SHELL and WANTED_GUI are set to “auto” too, actually I never modified /etc/sysconfig/yast, didn’t find anything related there.

Do this as I explain here, to become root
Terminal

su -

https://forums.opensuse.org/showthread.php/534874-yast-software-manager-sw_single-has-small-hard-to-see-symbols-for-status?p=2893792#post2893792

You mean changing the display (KDE) settings for the root account? It makes sense, will try that.

I also had very small ones, and you did not understand what was installed and what was not, the only way I found to modify them was what I suggested, now I have them, the change is not immediate you have to restart
https://i.postimg.cc/9D5tY9Px/Screenshot-20190208-202053.png](https://postimg.cc/9D5tY9Px)

Yast runs under root so it uses themes defined for the root user.

Assuming that, you’ve all the needed Oxygen(5) packages installed, oxygen5, oxygen5-cursors, oxygen5-decoration, oxygen5-icon-theme, oxygen5-icon-theme-large, oxygen5-lang, oxygen5-sounds, oxygen5-style and yast2-branding-openSUSE-Oxygen, and yast2-branding-openSUSE, after you’ve set the KDE Plasma Application Style, Icon style and Window decoration to “Oxygen”, logout.

  • Then, via a VT TTY session, either, execute “kbuildsycoca5
    ” or, simply empty the ~/.cache/ directory or, at least remove the following from the ~/.cache/ directory:

ksycoca5*; plasma*; icon*; qt_compose*.
Then, login to the KDE Plasma session …

My mistake:

  • For YaST you ned to do this for the user “root” …

dcurtisfra, of course you were right, it is the root settings that we need to change. Strangely, I already had the Oxygen icons selected in my opening post screenshot, but looks like some of them changed recently, and that is what confused me.

I also could get rid of the new icons in the software manager (that made it very difficult to see what is going on there with the packages) into the ones in
enziosavio’s screenshot.

Well, actually I don’t know how I managed to trash the Breeze icons by removing all .kde4, .config and other config stuff from the root account home. Some of the icons from Breeze changed and Breeze Dark icon theme disappeared (symlinks were missing) :-? Had to reinstall the corresponding package.