Yast over SSH not rendering properly

This is a bit of weird one. Yast isn’t something I access very regularly, but from what I can tell, this has only started happening since a recent update to Tumbleweed. Basically, via the console, Yast renders fine, but via SSH, certain elements are broken. I’ve tried Terminal on macOS, iTerm2 and Putty on Windows. All have similar rendering issues. See screenshots below. This is happening on both a newly installed tumbleweed server from a freshly downloaded ISO, and an existing server that’s just been fully updated.

Does anyone know what could be causes this?


Appears to be a font problem. Do you know what font is assigned to the terminal? Note all pictures are wrong

Try SSH using an xterm console when you’re connecting from a Linux box.
Or, when you are using PuTTY, try another emulator setting.

Another thread complained of an issue similar to yours, and I suspect the same solution should work for you (some setting in the enhanced console of your Desktop has changed).

If xterm works for you,
Pls submit a bug describing your problem and the solution to https://bugzilla.opensuse.org.


I’m using a relatively fresh install of macOS Sierra. Installed only a couple months ago. I’ve also logged as a guest user to eliminate my profile as a potential source of weirdness, but alas, same result. Terminal is set to xterm, but I’ve tried all the others. The VT emulators fix the question marks and render proper lines, but they introduce other rendering problems, like no blue background in yast, and navigation issues.

Do other people here not use macOS? I’m running new macOS connecting to a new install of Tumbleweed using the macOS Terminal. It’s not like I’m doing anything weird here.

Maybe you should submit a bug report to MacOS? rotfl!

AFAIK most terminals have ways to customize basic color themes like font and background (and usually not much more).
So, that’s most likely your next step.


It’s a terminfo bug perhaps…

@OP, after login via ssh, then run the command screen, then yast… it’s just a work around until things get fixed.

There are a couple of open ones: https://bugzilla.opensuse.org/show_bug.cgi?id=930110 and https://bugzilla.opensuse.org/show_bug.cgi?id=1056020

I used the screen command without root and it worked great thanks for your help.