yast opens but none or the yast icons will open

Tumbleweed 42.3 KDE.
I read this post: https://forums.opensuse.org/showthread.php/520744-yast-isn-t-working?highlight=yast2+bootloader+doesn't+open

so I ran the command that was posted and got this result:

zypper lr -d
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias                                | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                     | Service
1 | openSUSE-20170802-0                  | openSUSE-20170802-0         | No      | ----      | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-Kingston_DT_101_G2_0013729B67AEBA802633017A-0:0-part2 |        
2 | packman.inode.at-openSUSE_Tumbleweed | Packman Repository          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/                                       |        
3 | repo-debug                           | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                                 |        
4 | repo-non-oss                         | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                                   |        
5 | repo-oss                             | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                                       |        
6 | repo-source                          | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                                |        
7 | repo-update                          | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/

I don’t know if this has any information that will help or not.
Yast opens but nothing else will open when I click on it. I tried bootloader first and then tried others. No yast2 would open.

What do I need to do to fix this?

The strange thing here is that you say you run TUMBLEWEED in the prefix of your thread title and that you then say “Tumbleweed 42.3 KDE” in your post. The last thing does not exist. It either the one or the other.

But your list tells us that you have only the standard repo and Packman and that they are all Tumbleweed ones. So that is fine and probably not the source of your problem.

You could start a terminal emulator (like Konsole) as root and try


Maybe it shows errors.

QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0                                                                                
Run command: /sbin/yast2 bootloader &                                                                                                                                 
terminate called after throwing an instance of 'YUIPluginException'                                                                                                   
  what():  Couldn't load plug-in qt                                                                                                                                   
/sbin/yast2: line 448:  4267 Aborted                 (core dumped) $ybindir/y2start $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS                              

Yast opened but none of the icons opened.

First a general remark. Please copy/paste complete: prompt, command, output, nextprompt. Now we have only the output and we have to assume dsome things, which is not a good idea when trying to debug something.


boven:~ # yast2
boven:~ #

Those prompts are important to be seen in many (also this) cases.

But, there are some errors there.
Nothing that I can solve in a wink. I hope others tune in.

Update/Install the following packages:


linux-h65n:/home/hw-suse # boven:~ # yast2
If 'boven:~' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf boven:~

linux-h65n:/home/hw-suse # boven:~ #
If 'boven:~' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf boven:~

Since I am mostly gui and not familiar with zypper, I am not sure how to install or update. Found how to install with zypper.

I have gotten the files

Update/Install the following packages:
installed and yast is now working again. Thanks.

Ishowed you an exampleon how it looks when you copy/paste prompt, command, output (well, there isn’t much output in my example) and next prompt. This is not something you should try to execute anywhere.

But the way you show things, including the prompt inux-h65n:/home/hw-suse # is exactly what want to tell you. Thanks.

> Since I am mostly gui and not familiar with zypper
i have never used the gui so cannot say for certain if your update methods are correct, but after your next ‘update’ try zypper dup and see what happens (this is the correct and most popular method for updating TW). Just ‘updating’ as is done with leap will eventually result in problems.