Yast not working

Hi all - newbie here

just installed suse 42.1 KDE. Although I have internet connection on boot, yast makes a connection and immediately loses it. Checking the logs as per message, there is a fatal error but what the error is I can’t tell. I have tried a re-install and although connection was made to yast [updates started down loading] the connection was lost after about half an hour. Its has not connected since then. Anyone have any ideas what may be the cause? Would installing the Gnome version make any difference?

many thanks


You wrote Yast is not working - it looks like the internet connection is not working and I don’t think there is any difference between KDE and Gnome. Are you using ethernet cable or wireless connection? Have you had a good internet connection with your previous set-up (opensuse 13.2?)?

Hi Uli - thanks for quick response.

I have an ethernet connection and this has worked with no issues using Ubuntu & Mint. This the first OpenSuse I have tried. I have a constant internet connection for firefox but I guess I am not connecting to the Yast server, [rather than Yast not working - sorry] although an attempt is being made on boot. The Fatal error occurs almost immediately.


Some ideas…

  1. Perhaps the errors, timeouts… etc are due to a problematic mirror?


  1. Try using zypper CLI instead
zypper clean
zypper up

If you get errors, copy/paste here for others to review.

  1. Another option is to examine /var/log/YaST2/y2log for errors. It is lengthy, so you might want to consider launching YaST Online Update, and watching output in a terminal
sudo tail -f /var/log/YaST2/y2log

When you get errors, you can terminate the tail and copy/paste the errors here.