Yast not working correctly

I have had this problem for about 2 weeks now. Quite a few of the
modules in yast give me this error. Error loading language plugin
/usr/lib64/Yast2/plugin/libpy2lang_perl.so libperl.so cannot open shared
object. I can’t say when it happened for sure. I was installing
different programs to play and copy DVDs and installed the Gnome base
system to give it a try around the time it quit working. I am using
Opensuse 11.0 64 bit KDE 4.1.3. I can install packages and manage
repositories, but the one click install does not work or the
partitioner. I have found a few posts with same problem, but everything
in them has not worked for me. Only other choice I can think of is to
reformat and install again but would rather find a way to fix it. I have
just about got everything how I want it.
Thanks for your help


cjck4

cjck4’s Profile: http://forums.opensuse.org/member.php?userid=1325
View this thread: http://forums.opensuse.org/showthread.php?t=400801

The particular file ‘/usr/lib64/Yast2/plugin/libpy2lang_perl.so’ is
provided by yast2-perl-bindings package. Hopefully, its as simple as
reinstalling this package with:

zypper in --force yast2-perl-bindings

Any of the gurus around here have any suggestions?


deano_ferrari

deano_ferrari’s Profile: http://forums.opensuse.org/member.php?userid=122
View this thread: http://forums.opensuse.org/showthread.php?t=400801

I tried zypper in --force yast2-perl-bindings with no change. I then did
zypper in yast*. Still did not work. Then I completely uninstalled yast
with zypper disabled all the repos but the DVD and then reinstalled. It
still gives me then same error on some of the modules when I try to use
it. There must be something that I installed that is in conflict.

Thanks for your help


cjck4

cjck4’s Profile: http://forums.opensuse.org/member.php?userid=1325
View this thread: http://forums.opensuse.org/showthread.php?t=400801

Ok, you have 64 bit system, so what is the output of

rpm -ql perl |grep libperl.so

For reference I get this (with 32 bit system):

> rpm -ql perl |grep libperl.so
> /usr/lib/perl5/5.10.0/i586-linux-thread-multi/CORE/libperl.so

Check that you have 64 bit perl package(s) installed.


deano_ferrari

deano_ferrari’s Profile: http://forums.opensuse.org/member.php?userid=122
View this thread: http://forums.opensuse.org/showthread.php?t=400801

"Ok, you have 64 bit system, so what is the output of

rpm -ql perl |grep libperl.so"

I am getting

/usr/lib/perl5/5.10.0/x86_64-linux-thread-multi/CORE/libperl.so

It is showing 64 bit installed
Thanks


cjck4

cjck4’s Profile: http://forums.opensuse.org/member.php?userid=1325
View this thread: http://forums.opensuse.org/showthread.php?t=400801

What does ‘zypper ve’ report? I would make sure all the recently
installed packages are 64 bit. Maybe also worth reinstalling perl
packages? Can’t think what else might be the cause…


deano_ferrari

deano_ferrari’s Profile: http://forums.opensuse.org/member.php?userid=122
View this thread: http://forums.opensuse.org/showthread.php?t=400801

>“What does ‘zypper ve’ report?”

Dependencies of all installed packages are satisfied.

I also tried rpm -ql perl |grep libpy2lang_perl.so just to see. It came
back with nothing(don’t know if that helps). I then tried zypper in
libpy2lang_perl.so and got this.

‘libpy2lang_perl.so’ not found.
Nothing to do.

One good thing about all of this I am learning a lot about zypper and I
like it. I will just keep trying things and maybe wait till 11.1 come
out to format.

Thanks for all of your help


cjck4

cjck4’s Profile: http://forums.opensuse.org/member.php?userid=1325
View this thread: http://forums.opensuse.org/showthread.php?t=400801