Yast not showing printer drivers

I have just installed Leap 15.2.

I tried to configure a printer but neither Yast nor Yast2 show any drivers!

The ppd files are in the system so any idea what’s going on?

The lpinfo command can be used to show al available drivers…

/usr/sbin/lpinfo -m

This can check installed open-source printer driver packages…

rpm -qa|egrep -i "post|ghost|guten"

With regards to your printer, how is it attached? Make and model?

Further to the above, it may be that YaST has not been able to automatically determine a suitable driver (as opposed to none being available). Explained here…


Sometimes, a vendor-supplied driver is required. With the printer hardware details someone should be able to provide guidance for manual configuration if necessary.


lpinfo shows lots of ppd files.

The printer is HP Deskjet 2633 via a JetDirect device so a network printer.

I tried telling yast that it was an Epson, a canon also but still got the same result. That is, yast shows no drivers.

Use a USB-Cable then as root:


And follow the instructions.

OK. Here is what has happened using yast2 printer

Select network printer from screen 1.

Using connection wizard, establish the link to the JetDirect. In the box that says to enter the printer manufucture, put anything except one of the names on the list.

It then goes on to the driver page displaying “Any Model” in the text display box. Then it displays every single driver I have on the box!

On this screen, you can enter whatever you like in the model selection box and it will immediately switch back to “Any Model”.