Yast not opening

Thanks for tip.
i am away from pc now.Will give it a try.
May be it is because of alsa OR pulseaudio.
Will be back when apply the commands.

hi. i also had a problem with package management. The guys here helped me to solve. Look here
maybe helps you too

Ok… As a note: this tread is starting to get confusing (with the different issues/subjects coming through)! :slight_smile:

If YaST (the GUI version) does start when run from a terminal console, but it won’t start from the menu (you get the prompt for a password but no GUI after that) it could be an older issue playing up that has to do with the sudoers setup (YaST gets launched for users using gnomesu or kdesu).

Check this thread here (mainly post #10) : Get “incorrect Password; Please Try Again.” In Kde - openSUSE Forums
& Correct Root Password Not Accepted! - openSUSE Forums


Thanks magic31.tried your solutions.now getting this error while opening in terminal.

linux:~ # yast2
No protocol specified

(y2controlcenter-gnome:3896): Gtk-WARNING **: cannot open display: :0.0

gnomesu yast2
No protocol specified

(gnomesu:4000): Gtk-WARNING **: cannot open display: :0.0

Thanks bcrisciotti for the post,but that solution is for 10.3 not for 11.0 as magic31 mention there.so i am afraid that it will broke up all the things.

I’ve had a look at recent bugs for alsa and I think it is a problem with the alsa sound system as it was on your install disk but has now been fixed by patch.

I wonder if shutting down alsa will work so you can get the update. In a terminal as root try: rcalsasound stop.

The problem may also be with pulseaudio so try: pulseaudio -k

Tried this,no luck.
Any ideas.
I am stuck here,cant do any thing.

The cannot open display : 0.0 is saying that the YaST GUI can’t find your X session/desktop to place the window on.

My first guess would be to focus on your display setup by checking the configuration in SAX ( normally YaST > Graphics Card and Monitor configuration - try running sax2 on the terminal prompt. )

You could post /etc/X11/xorg.conf to see what’s been configured there.

Two additional things:
-Disable compiz if you have it enabled (just to see if it works then)
-Do you have two monitors setup by any chance? A crooked display configuration could also result in these messages.

Compiz is disabled, just 3D is enabled.which is from the 1st day.
Nope.i have one monitor conf.
data from /etc/X11/xorg.conf, hope this will help to sort out.


SaX generated X11 config file

Created on: 2008-07-10T10:31:47+0800.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)


Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”

Section “ServerFlags”
Option “AIGLX” “on”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”

Section “Module”
Load “extmod”
Load “type1”
Load “glx”
Load “freetype”
Load “dbe”
Load “dri”

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “Logitech USB Optical Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”

Section “Monitor”
DisplaySize 305 230
HorizSync 31-64
Identifier “Monitor[0]”
ModelName “1280X1024@60HZ”
Option “PreferredMode” “1280x1024”
VendorName “–> VESA”
VertRefresh 50-60
UseModes “Modes[0]”

Section “Modes”
Identifier “Modes[0]”

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 16
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 24
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 8
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”

Section “Device”
BoardName “i845”
BusID “0:2:0”
Driver “intel”
Identifier “Device[0]”
Option “monitor-VGA” “Monitor[0]”
Screen 0
VendorName “Intel”

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”

Section “DRI”
Group “video”
Mode 0660

Section “Extensions”
Option “Composite” “on”

Just update the system from terminal.
Now opening yast GUI from terminal, but again same problem with opening new window from yast.

Sorry for the late reply, missed your post.

At first glimps your xorg.conf looks fine…

With YaST, can you open the modules separately, or does this also fail? For example open a terminal console and;
su - (& root pw)
yast2 lan &
yast2 sw_single &

  • you can find other modules to enter in the console by hitting tab twice after 'yast2 ’

There is one thing you could try to do to see if this issue is related to your graphics configuration. This will reset your current xorg and setup a fresh one:

  1. reboot your system and at the boot screen enter ’ init 3 ’ as boot option - this will boot up to the console login prompt.
  2. login as root
  3. cd /etc/X11
  4. mv xorg.conf xorg.conf.lastgood
  5. sax2 -r
  6. Configure the settings as you want them, save and reboot.

Hopefully that sets things right…

If you want to revert to your old config do steps 1 & 2 and as last
rm xorg.conf
cp xorg.conf.lastgood xorg.conf

Hope that helps,

With YaST, can you open the modules separately, or does this also fail? For example open a terminal console and;
su - (& root pw)
yast2 lan &
yast2 sw_single &

Will try this as already reinstalled the graphic through the method you mention. the same problem still exist.

Anyway thanks for being in touch.

Will back soon with the results.

I have tried your way, and get the following results.
It means, its not opening it from this way also.

yast2 firewall &
[2] 7766
linux:~ # No protocol specified

(y2base:7784): Gtk-WARNING **: cannot open display: :0.0

[2]- Exit 1 yast2 firewall
linux:~ #

Sorry to say I’m running out of ideas…

Just to test to see if it’s something user specific, have you tried logging in as root and run YaST from there?
Or maybe just create a new test account…

Do you remember when it worked the last time? And what happened before it ‘broke’?

I am not sure about the exact time,but i think around 10 days ago.
Actually i am using it in office, one day i start PC with normal conf,it update some thing(i did not check that time).
The next day when i try to open it,it was not working.
Even that i did not install anything extra.
I think the problem came from that repo update.not sure what it update that time.
Anyway thanks,i will try with diff username and with root too.
Lets c,what is result.

Just tried with root and another user account.
Working fine there.
Not sure why not working in this account.Which i modify a lot for myself. Cant change account now.
Its ok, Will try to do something with other account to make it usable.

some strange is this, if i want to open any thing under terminal bcoz of root permissions. Same results as yast2.
Have a look:

linux:~ # gedit /etc/X11/xorg.conf
No protocol specified
cannot open display:
Run ‘gedit --help’ to see a full list of available command line options.

I don’t think so,that my command is wrong.Is it wrong?
With root and other accounts its working fine.

I’m guessing here, but there is a file .Xauthority thats generated the first time when redirecting things from the terminal to the X gui.
Maybe deleting/renaming that file and the opening a new terminal console will de the trick…
Your solution will probably be somewhere down that road…
Take care to backup before deleting files you are not sure about :wink:

Where can i find that file,checked etc/X11. its not there.

ok, got it.its in home folder.

Tried your solution, same thing like b4.

try run this command in terminal as root.

yast --qt

or this (not as root)

gnomesu /sbin/yast --qt

and this (not as root)

kdesu /sbin/yast --qt

does it solve your problem ?

Good tip to try, and just as note : this (-qt switch) will only work if you also have the QT environment packages installed. Generally you will only get this if you have KDE or KDE specific applications installed…

Using the GNOME DE (and other non qt DE’s) you will only have GTK as ‘framework’ library.

If you get an error about not having qt or gtk you will need to install the libraries first (assuming you want to do this).
(imo) The qt environment does offer more options and has a sleeker look to it.