Yast not opening

I am trying to open Yast and install some softwares.
It ask me for password,but then nothing is opening.
I tried on install software link also.
same behavior from both.password then not showing window.
Any ideas…

Try opening a terminal and trying the ncurses-based yast.

I tried like this:

linux:~ # ncurses-based
-bash: ncurses-based: command not found
linux:~ # ncurses-based yast
-bash: ncurses-based: command not found

Sorry, ncurses-based, means the terminal version. Open up a terminal and type:


Ok thanks,it works.
i search there install software soem thing similar,but cant find it in terminal based yast.
So mean i cannot open the GUI yast anymore.i want to use install software window.
any idea.

Ok,i find it.
Still my question remains:
So mean i cannot open the GUI yast anymore?

No, you should be able to install or fix problems from the terminal based yast, so that you can get back into a gui.

Why can’t you get into a gui. When you first boot your computer, what happens?

Can you try typing “kdm” from a terminal? Will that load kdm, or does it crash? Does it load, but only to a black screen?

What about running “startx” ?

Everything is working fine.
When i boot computer,no errors.boot fine.
Then Login as my username without any problem.
I am using gnome not kdm.
Everything is working.every software is running well except Firefox.it crashes most of the time.so alternatively i am using Flock.Today i tried to open yast to install some software from software management.but after entering password nothing appear.
No black screen,desktop is there.
One thing i note.some time the software updating failed when i boot pc.Not sure about that,why its crashing.

What about if you use a terminal as su and type in yast2 (the gui yast). Do you get any errors showing up?

Thanks,its open it in terminal as GUI.
But when i click on software management,nothing appear.
then i close yast2.and get to terminal again and get this:

linux:~ # yast2
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

Do you get a screen or error when launching the YaST GUI from a terminal console, using:

su - (enter root pw)
yast2 &

Using your command yast2 &.it opens it but in terminal throw this:

linux:~ # yast2 &
[1] 4679

ALSA is the sound system. Any problems with your sound? Will YaST or YaST2 open Hardware > Sound?

I’m having the same problem.

Yesterday I installed opensuse 11 with gnome from the liveCD, made my network connection and add the community repos from YaST (all of them).
It says something about the Education repo (cannot find network address or sth., I’m now at work but tonight i’l try to post the exact error message).:slight_smile:

After updating and a reboot I get back into Gnome GUI without any problems, but when I’m trying to start yast to install some software, it gets my root pass, but isn’t starting.:confused:

I tried to reinstall from the DVD with the same result if installing Gnome (if KDE4 everything goes fine):slight_smile:

Anyone with a suggestions what to do (I’m a complete noob):rolleyes:

Other threads have commented on the problem with the education repo. Try unsubscribing from it until things are sorted. If you are able to, do this: start YaST > Software Repositories. Find the education repository. Highlight it and then uncheck the ‘enabled’ box. Save and exit. Exit and restart YaST and hopefully installing software should work for you…

I am using it in office,so there is no sound system for me.
The thing is not about sound.
Actually yast2 i can open by terminal,but when i select install software OR software management,nothing appears.
So mean i cant use install software window.
Just tried other selections from yast2,no one is opening.
Not sure.

Oh, thanks for the quick responce, but I’ve allready did this.

And I’ve found my error message in another post, here is the link to the message pic:

Picasa Web Albums - Martin - openSuse 11 s…

when clicking on Details it’s about the Edu repo

Ok, the way I described worked for me in KDE but obviously not for Gnome:) How about opening a terminal window and typing:

su (then root password)

That should open up a non gui version of YaST. See if that will let you unsubscribe from the edu repo.

I’l try this tonight but probably I’ll need some help with the terminal commands (as I said, I’m a complete newbie in Linux:))

I’ve had a look at recent bugs for alsa and I think it is a problem with the alsa sound system as it was on your install disk but has now been fixed by patch.

I wonder if shutting down alsa will work so you can get the update. In a terminal as root try: rcalsasound stop.

The problem may also be with pulseaudio so try: pulseaudio -k

Hope that helps:)