YaST LDAP Exception

I am getting this error

terminate called after throwing an instance of ‘LDAPException’
what(): Local error
YaST got signal 6 at YCP file Ldap.ycp:3
/sbin/yast2: line 423: 2933 Aborted $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

when I click
A. Fetch DN under LDAP Client
B. Click OK to Browse under LDAP Browser
C. Click Samba Server and it gets to the backend stage of loading
D. Click Autofs then click ok afer entering server IP

This is a new/first install of LDAP on a new openSUSE 11.4 64 bit
Downloaded 4 days ago.
Gigabyte 890FXA-UD5, 8 gig, 1tb Sata 3

Configuring Open LDAP server through YaST is good.

GQ ldap client seems ok. Can see the database but can’t expand the tree but that just might be I haven’t learned enough about LDAP yet.

Tried a few things based on forum/google searches.
A. removed LDAP client and reinstalled
B. removed and installed LDAP server and browser also
C. tried TLS on/off
D. Tried LDAPI on/off
E. deleted and reinstalled databases
F. tried database with/without administrator passwords

Based on the forums and similar exception messages I am thinking this could be a YaST issue and not LDAP.
Some discussed 32 bit libraries being used where 64 bit belong.
Some mentioned 64 bit libraries that were not showing up in /usr/lib64

I am sure it is something I changed since LDAP in Yast was working at one point.
I have only been making changes through YaST.

I did try the gtk version of YaST2 (same problem)


Thank-you for considering my problem

What happens if you run ‘su -c yast’ in a terminal. You’ll get the ncurses version of Yast, the nice retro style blue/white/yellow screens.

LDAP Client closes without any configuration save sentences when I choose fetch or advanced admin
LDAP Broswer closes without any configuration save sentences when I choose OK or Anonymous
Samba tries to start but cancels when gets to backend message
Autofs same

LDAP Server closes fine with save config changes messages

can close this post
I reinstalled Linux and have not been able to repeat the issue