YaST Keeps Downloading repodata

How do I stop YaST from downloading the repodata every time I open the software manager?
Even if I have opened it 5 minutes before, YaST still downloads the repomd.xml again.

This is also a real pain if I am offline and trying to install an rpm, because I have to wait for it to realise that it can’t access the data before it allows me to skip the auto-refresh.

By the time that happens I could have installed the software already if I was using a debian or windows based system.

In YaST go to Software Repositories and untick the “Automatically refresh” checkbox for each repo. Then click “OK”. However I keep mine enabled and you will need to refresh the repos yourself manually.

From what it looks like, download.opensuse.org is down. If you use repos, refresh them.

As Knurpht pointed out this issue should resolve itself once download.opensuse.org comes back up. However if you want to disable the auto refresh of repos anyway look at my post above.

Thanks. .