Yast Is Not Working!

Hi friends
i tried to install lib4qt to install Krita but yast has encountered an error so i aborted the process after several tryes & after few seconds i tryed to run yast again but its not coming up & no error also!
what do you advise me to repair yast?

Boot to runlevel 3 and login as user, become su
then start yast with: yast

If it works:
Go to software management, filter by repo
select ‘system’
do update all in this list unconditionally

when done

Sorry i forgot my Balouch user’s pass & also secret answer so i’ll be here with this username after this!

i rebooted my pc after that post but now i cant have access to GUI & im able to use command line mode only!
is there any idea to login to graphical mode? im newbie to linux & its too hard for me to use command line!

Did you able to go to login screen, if not.
In command line, type su and enter your root and then type startx.
It will bring you back to GUI.
Give it a try.

ok. wait a while i’ll try in command line & tell you back in just few moments

Thanks sir, now X is up but with a little problem!
i prefer the KDE but KDM has damaged i think! when i try to start X it comes to GNome automatically & when i try to logout & log back in to KDE, it goes to command line mode again & when i tryed to reinstall the KDM with yast there was too many problems to install that!
now i have no idea to solve this! what do you advise to do?

ok, i tried the gdm & that is working fine but when ever i set my display manager to kdm, it goes to command line mode & i haveto start X manualy & also i cant login to KDE! i choose kde 4.3 from DM but it comes to Gnome!!!

try out this:

Programming and Linux: Howto: Login screen gone [solution in openSUSE (kde4)]

i didnt found the line DISMPLAYMANAGER_KDM_THEME=“xxxxx” in /etc/sysconfig/displaymanager !!!
any idea?

It should look like this:
Its the 6th line from bottom.


Open a terminal and do:

cat  /etc/sysconfig/displaymanager

you can edit with
gnomesu gedit /etc/sysconfig/displaymanager

kdesu kwrite /etc/sysconfig/displaymanager

This is mine

Path: Desktop/Display manager

Description: settings to generate a proper displaymanager config

Type: string(kdm,kdm3,kdm4,xdm,gdm,wdm,console)

Default: “”

Here you can set the default Display manager (kdm/xdm/gdm/wdm/console).

all changes in this file require a restart of the displaymanager


Type: yesno

Default: no

Allow remote access (XDMCP) to your display manager (xdm/kdm/gdm). Please note

that a modified kdm or xdm configuration, e.g. by KDE control center

will not be changed. For gdm, values will be updated after change.

XDMCP service should run only on trusted networks and you have to disable

firewall for interfaces, where you want to provide this service.


Type: yesno

Default: no

Allow remote access of the user root to your display manager. Note

that root can never login if DISPLAYMANAGER_SHUTDOWN is “auto” and

System/Security/Permissions/PERMISSION_SECURITY is “paranoid”


Type: yesno

Default: yes

Let the displaymanager start a local Xserver.

Set to “no” for remote-access only.

Set to “no” on architectures without any Xserver (e.g. s390/s390x).


Type: yesno

Default: no

TCP port 6000 of Xserver. When set to “no” (default) Xserver is

started with “-nolisten tcp”. Only set this to “yes” if you really

need to. Remote X service should run only on trusted networks and

you have to disable firewall for interfaces, where you want to

provide this service. Use ssh X11 port forwarding whenever possible.


Type: string


Define the user whom should get logged in without request. If string

is empty, display standard login dialog.


Type: yesno

Default: no

Allow all users to login without password, but ask for the user, if



Type: yesno

Default: no

Display a combobox for Active Directory domains.


Type: list(root,all,none,auto)

Default: auto

Determine who will be able to shutdown or reboot the system in kdm

and gdm. Valid values are: “root” (only root can shutdown), “all”

(everybody can shutdown), “none” (nobody can shutdown from

displaymanager), “auto” (follow

System/Security/Permissions/PERMISSION_SECURITY to decide: "easy

local" is equal to “all”, everything else is equal to “root”). Note

that remote user can never shutdown in GDM.


Type: string

Default: “”

Mode to configure on output devices by default

(RANDR 1.2 compatible drivers only).

If set to “auto”, DISPLAYMANAGER_RANDR_MODE_auto is used on laptops, and

the empty string on workstations.

The output is not explicitly enabled (read: disabled) if set to an empty


If the variable contains a fully configured modeline (see default of

DISPLAYMANAGER_RANDR_MODE_auto), the mode is defined and set.

If the variable contains a mode name only, the mode has to be defined


If a monitor is attached during Xstartup, or when invoking “xrandr --auto”

during runtime, the output is correctly configured and a mode is

automatically selected if none has been used so far.

Variables are checked according to their extension for

VGA DVI_I DVI_D DVI_A Composite S_Video Component LFP Proprietary


Type: string

Default: “1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync”

Mode to use for laptops for DISPLAYMANAGER_RANDR_MODE_* on laptops only,

when the according variable is set to “auto”.

(RANDR 1.2 compatible drivers only).

DISPLAYMANAGER_RANDR_MODE_auto=“1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync”

Path: Desktop/Display manager

Description: settings to generate a proper displaymanager config

Type: string


Config: kdm3

space separated list of users for which icons should be shown in KDM

if empty, then take system defaults


Type: string


Special greeting words in kdm


Type: string


Defines extra Server Arguments given to the kdm display manager when

starting a local display. Useful to override e.g. the -dpi setting.


Type: string

Default: SUSE

Define the theme to be used by kdm. If empty, the traditional login

window is used (which lacks some features)


Type: string(Xorg)

Path: Desktop/Display manager

Default: “Xorg”


its completely different for me!
look @ this image: http://marmolak.net/images/65s1gbcno1o0t1e6n0vk_thumb.jpg](http://marmolak.net/viewer.php?file=65s1gbcno1o0t1e6n0vk.jpg)

i could login to KDE3 finally but not any package running there :frowning: for example im not able to manage my connections & …
when i tried to start yast on kde3 i recived an error like this:

YaST got signal 6 at YCP file Wizard.ycp:691
/sbin/yast2: line 437:  4771 Aborted                 $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

i recived this error once befor damaging kde!!! but Yast is still working pretty good in Gnome!

OK. So post result of this:

zypper lr --details


#  | Alias                | Name                  | Enabled | Refresh | Priority | Type     | URI                                                                                        | Service
1  | 20090629-075556      | 20090629-075556       | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/KDE%3a/KDE4%3a/Factory%3a/Desktop/openSUSE_11.1/ |        
2  | Libdvdcss repository | Libdvdcss repository  | Yes     | Yes     |   99     | rpm-md   | http://suse.linuxin.dk/repo/11.1/                                                          |        
3  | LocalHDD             | LocalHDD              | Yes     | Yes     |   99     | plaindir | dir:///home/mansoor/Downloads                                                              |        
4  | Packman Repository   | Packman Repository    | Yes     | Yes     |   99     | rpm-md   | http://ftp.skynet.be/pub/packman/suse/11.1/                                                |        
5  | devel:tools:building | devel:tools:building  | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/devel:/tools:/building/openSUSE_11.1/            |        
6  | mozilla              | mozilla               | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/mozilla/openSUSE_11.1/                           |        
7  | openSUSE:11.1:Update | openSUSE:11.1:Update  | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/11.1/                                                  |        
8  | repo-debug           | openSUSE-11.1-Debug   | Yes     | Yes     |  100     | yast2    | http://download.opensuse.org/debug/distribution/11.1/repo/oss/                             |        
9  | repo-non-oss         | openSUSE-11.1-Non-Oss | Yes     | No      |   99     | yast2    | http://download.opensuse.org/distribution/11.1/repo/non-oss/                               |        
10 | repo-oss             | openSUSE-11.1-Oss     | Yes     | No      |   99     | yast2    | http://download.opensuse.org/distribution/11.1/repo/oss/                                   |        
11 | repo-source          | openSUSE-11.1-Source  | Yes     | Yes     |  100     | yast2    | http://download.opensuse.org/source/distribution/11.1/repo/oss/                            |        
12 | repo-update          | openSUSE-11.1-Update  | Yes     | No      |   99     | rpm-md   | http://download.opensuse.org/update/11.1/     

Those look OK
So what is your display manager setting. I highlighted mine in Red.

its just kdm for me & was working pretty well befor. but its not working right now & i changed to gdm

cant be this problem fot libqt4??? i gues something wrong (missing) with QT!! i tryed to reinsall that but im reciving checksum error for libqt4-x11
is there any advise?

hi guys

finally i solved the pro!
i just logged in to Gnome & updatet my kde completely after running yast package manager.
but here is a new unbelievable problem! when ever i choose to update Amarok, it advises me to downgrade it!!!
this problem occured with several packages but all of them updated succesfully but its still with amarok engine!!!

at least i want to thank caf4926 for kindly help, thanks bro :slight_smile:

The amarok problem will depend on which version you have.
Updates will offer:
amarok 1.4
kde4-amarok 2.*

Packman offers:
amarok 1.4
But it’s not the same as the one from suse updates.

I’m not clear on if you use kde4 or kde3 or both, gnome yes I know.

To be honest I would recommend forcing your install to use all multi-media from Packman. So you have to keep an eye on this when running updates.

Some reading:
Flash, k3b, Amarok - Install Guide - openSUSE Forums

Multi-media and Restricted Format Installation Guide - openSUSE Forums