YAST is broken after 12.3 upgrade

terminate called after throwing an instance of 'YUIPluginException'
  what():  Couldn't load plug-in qt
YaST got signal 6 at YCP file Wizard.ycp:720
/sbin/yast2: line 431: 10771 Aborted                 
$ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

Really not usre where to go with this one…? Doesnt let me luanch any of the options. It does let me launch the YAST application though.

Anybody else had this issue?

Thanks
William

“12.3 upgrade” is a bit vague. Upgrade from what to 12.3? Upgrade method used?

Followed the standard SUSE upgrade procedure on docs from 12.2 to 12.3

Seemed to work fine, but noticed there are lots of dependancy errors related to perl and geustfs-tools. And YAST seems to be totally burst when i click on anything related to package management.

William

I know of at least three methods to go from 12.2 to 12.3. None of them is defined as “standard” as far as I know. Why not tell what you did instead of assuming that we can read your brains.

Fixed. It would appear that the issue was related to this package that seemed to be corrupt because it was installed so I just removed and reinstalled it.


sudo zypper rm libyui-qt-pkg4
sudo zypper in libyui-qt-pkg4

This command installed and sorted the package.

Now its working fine. No zypper or YAST issues.

William

I am using GNOME and using yast2 for gnome.

Firat of all I can not see yast2 in the applications list and running from terminal in superuser mode i get the following error.

(y2controlcenter-gnome:8989): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

And on clicking on the any of the yast2 module, I get the following error.

terminate called after throwing an instance of 'YUIPluginException'
  what():  Couldn't load plug-in gtk
YaST got signal 6 at YCP file Wizard.ycp:1822
/sbin/yast2: line 431:  9125 Aborted                 $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

I am helpless. I search on so many blogs and tried so many solutions but it could not work for me. If I use QT version of yast it works but I like to use gnome one.

@prabhatkhera: Yo’uve tacked onto the end of someone else’s thread. You best advised to start your own, and provide as much relevant background info as possible, so we’re not left to guess details. Is this the result of a recent upgrade for example? Configured repos?