YaST is asking a CD instead of a DVD

Hi all,

I got a little problem installing OpenSuSE 11.1 from DVD. Everything is great until YaST is ready to install SuSE. It is asking for a CD instead of using the DVD. No matter what i do, i can’t get the dvd to work :.

I looked in the menu to load the drivers but they are not there. The only loaded drivers i found are CD-ROM drivers :(.

Please help me.

Kind regards and thanks.

Post terminal output:

zypper lr

Thank you for your reaction. This didn’t help, i tried a shell window (the only one i could find) and execute the command. Unfortunately the “unknown command” output came back. Did i something wrong? Or is there another way to do?

zypper lr should have an output
copy and paste it here

Try this SDB:CD not found problem - openSUSE

Though this a very old fix thought this would be solved by now, if this fixes it I would suggest a bug report.

The output of BASH is:

/ # zypper lr
bash: zypper: command not found
/ #

This is the only output i get :).

If the above one isn’t correct try this fix If Cd/dvd Installation Fails With “cannot Find Repository” - openSUSE Forums

I’m sorry and thank you for your help. This didn’t work. I was able to execute the command but i do not have a function or option called Jmicron in my BIOS settings. And allthough i use a dual core processor and SATA drives (hdd’s), i only can use my IDE (cdrom) drives.

copy and paste my text from this page in to the terminal:

zypper lr

Try the other one modules.pata though I would thought ide-generic would be the one I’ll continue googling. You’re looking for kernel parameter that you need to insert a module. Your other option might be a net install.

This is a really old problem wish the old forums were up I’d find the fix. What is the model of the PC or is it a black box? Or perhaps the drive details to assist the goggle search.

EDIT:
@Caf they don’t have any they haven’t installed a single pkg let alone set up repos.

There is a whole thread here, now that took some hunting Suse 10.1 Installation: Can’t Find Cdrom - openSUSE Forums

@Caf they don’t have any they haven’t installed a single pkg let alone set up repos.
Yep, I don’t know what I was thinking. Has a media check been run?

This didn’t help. It still asks for a CD instead of a DVD :frowning:

Boot the disc and run the media check from the menu

I’m going for a net install. Reading through the other thread(10.1) didn’t make pleasant reading many resorted to net installs or ide-sata converters.

If you have access to usb dvd drive perhaps that’ll do it.

If you can get a distro working i.e a live distro perhaps you can see what the difference is. Knoppix tends to be quite good for troubleshooting hardware.

I say this as I noticed one person tried all the parameters under the sun but couldn’t get it to go on Suse yet had no trouble with RH/Fed.

It is certainly worth bug reporting if you can get it installed, I’m sure it is related to the not so recent libata change. More so as you say you’re mixing ide with sata. I’m not being helped as the old archives are pretty unsearchable, but you’ve tried most of what I remembered that thread seems to have most of the fixes.

By the way I’m presuming you’ve done as Caf suggested and the disk is checking out fine.

You are absolutely right. What was i thinking… :confused:

My system contains the following:

  • Processor: AMD64 X2 Athlon XP (dual core)
  • HDD: WD 320 gb HDD (SATA)
  • RAM: 2 Gb RAM Memory
  • Graphics: Nvidia Geforce 7600 GT (256 Mb Memory)
  • Chipset: Nvidia V4 Chipset (Nforce or something)

Maybe this will help :slight_smile:

Need the details for the problem device it is the cd/dvd player we need and the mobo board so we can see what chipset.

I’m out of ideas tbh if this is really a nvidia nforce ide sata controller I can’t begin to imagine there is problems with it.

Perhaps someone else has some ideas, or perhaps try the bugzilla, but I thought this was going to be some obscure chipset, not something pretty main stream and regular.

The jmicron used to do this but this is several kernels back having not seen this for a long while can’t say I expected it to turn up now.

I’m still back to net install, I know this is a really stupid question but just got to ask we’re sure this is 11.1 and not 10.1?

I already did so but i get the same problem here. It is asking for a CD not a DVD.

The chipset is Nforce from Nvidia

DVD player: DVD RW AD-7170A (Optaric)
CD-rom player (i use this one as a cd-rom player): DVD_RW ND-3550A (NEC)

MOBO: Gygabyte GA-K8N Ultra-9