Yast Internet Access (IPV6 issue)

Hello, would anyone will be able to explain this phenomenon. I have a fresh install of OpenSUSE 11.4 with GNOME 3. Right out of the box, FireFox had no connection, so I typed about:config and turned off IPV6. Reboot. FF has internet, but Yast Software Management complained that it “Cannot access installation media”. I verified URL http://download.opensuse.org/update/11.4/repodata/repomd.xml and it seemed ok.
So I went to Yast Hostnames and removed all ipv6 hosts. Also went to Yast Network settings and unchecked Enable ipv6. Yast update gave the same error.
Went to


to verify and

net.ipv6.conf.all.disable_ipv6 = 1

was there as expected.

zypper lr -d

everything seemed ok. All URI’s pointed to “http://download.opensuse.org/…”
I am just not sure if I would want to download packages manually. Any help is appreciated.

Am curious whether the problem is what you might think…
First, I hope you simply renamed/copy or otherwise preserved any settings and entries you did so if desired you can always return to your “baseline.” If not, I think things like your IPv6 address can be automatically regenerated anyway.

Recommend a first test whether Zypper works which is the CLI equivalent of the GUI tools… The following command refreshes your local copy of the repository catalog

zypper refresh

Ideally, you should probably run that test both with IPv6 enabled and disabled.

Although I don’t know in detail the YAST application and networking stack (If an expert reading this thread is, pls comment), following ordinary principles I would think that YAST should not be maintaining its own resolver and networking cache.

Following this train of thought, I’d recommend flushing your client-side resolver cache. I don’t remember exactly how this is commonly done, but some quick research suggests invalidating current entries in the cache

nscd -i hosts


Tony, thanks for your reply. I tried “zypper refresh” and got this:

Retrieving repository 'Updates for openSUSE 11.4 11.4-0' metadata \]
Download (curl) error for 'http://download.opensuse.org/update/11.4/repodata/repomd.xml':
Error code: Connection failed
Error message: Couldn't resolve host 'download.opensuse.org'

I have done additional testing and have found that on some distros there is no net connection and the software update does not work. I have booted from the official cd images for each. This is strange, but someone might see a trend here:
OpenSUSE 11.4 KDE = Firefox - YES(ipv6 fix) and Software update - NO
OpenSUSE 11.4 GNOME3 = Firefox - YES(ipv6 fix) and Software update - NO
Fedora 15 Alpha = Firefox - YES(ipv6 fix) and Software update - YES
Ubuntu 10.10 = FireFox - YES(no fix needed) and Software update -YES

I am not sure, but this might be an exclusive OpenSUSE issue.

Is it possible you might be having a DNS issue yzubkov? I have a message #9 here that mentions many free DNS servers:

IPV6 disabling in Suse in general ?

I recently started having DNS issues getting to the openSUSE forums myself and switched to using a couple of the Level 3 ones and my problems seemed to go away. I have a wired router and put them in the router, but you can also put them into an individual computer.

Thank You,

I just went to Test your IPv6. and it said that “You appear to have no IPv6 at this time.”, altho I am on residential DSL. I have also spend a good 30 minutes browsing through my Network Router settings trying to find IPv6 specific configurations and could not find anything there. Anyone can suggest a free DNS that would support IPv6. Google has a free DNS but I think they are confused about weather they support IPv6 or not. At least I could not understand. Google DNS. Any help, or suggestions are appreciated. I have also tested Ubuntu Natty Beta 1, and Firefox did not need IPv6, however Software Update service required it.
I really hate to see all the major distros going IPv6 without the majority of PEOPLE having it.

Here’s an approach…

You may already know that the world’s DNS servers are designated to one of three tiers… The first tier are the 16+ root DNS servers (which should be mostly IPv6 by now), the second tier is typically the big authoritative servers anyone running their own DNS should forward requests and the third tier is generally at the ISP level (ie client machines should configure in their network settings).

Here is a listing of Tier 2 DNS servers, although I don’t specifically see a “Supports IPv6” property, I suspect that any of those listed that list an IPv6 address will support IPv6. :slight_smile:


You might also follow up with a query to the Admins of whatever DNS you’re currently having problems to ask them why they aren’t supporting IPv6 yet…


I got this issue resolved. Thanks to all for helping me figure out what was wrong. At first I thought there might be something wrong with my lan/network setup. Then I suspected that OpenSUSE was at fault. After wasting couple of days trying to figure out why my ifconfig showed eth0 device without any inet line, i finally came to the conclusion that my ISP is at fault. AT&T DSL is years behind in IP technology, they probably do not even know what ipv6 is. Anyways, browsing through dslreports, I found this site that lists all ISP’s that provide IPv6 natively (SixXS). Unfortunately there is only around 10 companies in US, and none of them are big names. What that means is that IPv6 will have to be forced onto the big Telcos/Cable Networks before it gains wide acceptance. They do not have any incentive to get moving.
As far as fixing the issue, I just did “vi /etc/resolv.conf” and replaced the existing nameserver lines with two nameserver entries. One with “” and another one with “”. So google after all does support IPv6, once again they are ahead of the race. After making this modification everything started working as expected.
What I cannot believe is that noone complained about this. Maybe all of you people live in Germany, or wherever, but down here in the boonies internet is just starting to gain popularity. There might be millions of people joining the net every day, and if they will have to go through what I have gone through, just to get online, then OpenSUSE/Ubuntu/Debian/Fedora/Mandriva… has no future. People will stick with MS because it works (poorly it may). They do not give a rat’s ass if this linux has a hardware accelerated GUI, supports IPv6, has the best partitioning system. All they care is that they can get to their Facebook profile, and upload music to their ipod. Until that level of usability is achieved, linux will remain supercomputer / server operating system.

On 04/13/2011 01:36 AM, yzubkov wrote:
> Until that level of usability is achieved, linux will remain
> supercomputer / server operating system.

and a damn fine desktop operating system for folks willing to pay the
price to drive the very best–quickly, securely and dependably.

i do not care one bit if Redmond keeps the game and front office,
nose-ring market.

CAVEAT: http://is.gd/bpoMD
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]
Q: Why do you upgrade?
A: Because the Gecko is always greener on the other side!
So said k428 in http://is.gd/Pwc3xq

I noticed the link to one of my posts that seems to have gone astray rather than sticking to the topic.
Can’t vouch for the modprobe stuff I posted but a look through kernle.org suggests editing modprobe.conf which should be in /etc but knowing suse may be some where else. I don’t think this will help though.

On this problem it is a suse issue that’s some what related to the kernel. The kernel had ipv6 add back in late 9.x suse befor Novel bought them out. It was issued as an upgrade and even activated. My system just about worked as it still does some times but never with YAST. Many peoples just wouldn’t work at all.
The real nature of the problem seems to be that the kernel will accept either IPV4 or IPV6. If a wired set up is being used there is a setting in yast for the ethx card that is being used to allow ipv4 or ipv6 or ipv4 only. Trouble is that no application program takes any notice of it and all apps may install just to use ipv6. Firefox does have the facilty to change that. I found a way of disabling it Konqueror as well but Konq doesn’t seem to take any notice of the KDE no IPV6 flag. FACT yast has no such facility and given the state of dns servers available automatically to typical home users it should have. Curious thing is that ipv6 data transfers seem to be ok on the few occassions that ipv6 dns actually works.

The change to the ethx config seems to change the same file that can be used to get Konq to work on the web – /etc/sysctl.conf. The line that needs uncommenting is obvious.

Any way I have filed it as a bug priority one and it seems to be holding. Not so another on Kmail spell check which has a bug but has been deamed a feature and don’t seeeem to be workin a t al l in fierfoc at the moment.

Mandriva and PCLinuxOS have the same ipv6 problem. I suspect they all have. A google on ipv6 problems brings up about 500,000 hits most relating to problems on many distro’s over many years. Much of the info there is clearly out of date and doesn’t work any more.


Last time I checked most SOHO routers do not support IPv6 so IPv6 routing is local hosts only, ie, internal to your network. I’m not sure if its the adapter or kernel that checks the routers for IPv6 capable and then assigns the IPv6 address numbers;
Which begin with FE80: equivalent to a 169.254.x.x address going nowhere.
Or might start with a FC00: allocation which would be private networks 192.168.x.x. but no public IPv6 addresses.

ifconfig would should the IPv6 address