Yast hates me

I’m just now coming back to Suse after a 4 or so year break. Downloaded the 11.1 32-bit DVD last night, installed at work today.

First off, best current installer on the free market - period. Installation was easier, more informative, and more configurable than anything else on the market - kudos.

The problem for me is that Yast hates me. Immediately after install I go to run my initial security update, fails. All kinds of errors. Sometimes Yast just dies, as in, it disappears off the screen with no errors or warnings. After 3 fresh installs of the DVD, I decide to try logging into the machine as root and running the update from there. This goes better, but is still finnicky and takes multiple attempts to complete. “Complete” is actually a false term as when it was all said and done, there were about 30 packages or so which failed to install after multiple attempts (about 3 hours worth actually).

Did a bunch of research here on the forums and found little to nothing. Ended up rebuilding my rpm db, and got probably another 18 or so of those remaining 30 packages installed. Trying to get the last dozen is frustrating to say the least. Yast sometimes dies (like it did just now, I’m rebooting the entire system as I type this). Sometimes hangs. Sometimes I swear it actually spits at me and I can hear it chuckle from the speaker.

ooooooooh. Nice new developement. That part in the last paragraph about rebooting. Well, it won’t boot anymore.
“Error 15: File not found, press any key to continue.”

Ah, looks likes its trying to run the pae kernel which was one of the packages it was having a hard time installing. Okay, off to reinstall number 4.

For those who like to chuckle at other’s misfortunes, I have spent two solid days trying to find a decent modern distro that I can get NVidia drivers to work for. RHEL, Ubuntu, XUbuntu, Mint, PCLinuxOS, Suse … next stop might have to be Fedora. Would really like to get Suse working though.

Have you tried to type

sudo zypper refresh
sudo zypper up

in terminal? This will install for you a lot of updates, for YaST Software Manager too.
Hope that helps.

No, but as soon as this installation is done, I’ll give that a shot before I do my first Yast update.

I’ll let you know how it goes.

You know what … it’s not Yast that hates me. It’s Suse.

So I finish install number 4, this time sticking with Gnome (previous installs were Xfce and two KDEs) since its the default. Take only the default packages during installation - no funky settings/options/changes whatsoever.

Log in as root first thing. Open up a terminal, run zypper refresh … looks good. Run zypper up - begins downloading ~245MB worth of packages. Get about 4 packages into it when I get some funky display issue (I think the screen saver tried to turn on, not sure). Anyway, I right-click on the desktop and select “Change desktop background”. The window comes up, but crashes about 2 seconds later. Now all the default applets in my desktop are crashing and dieing. Next thing I know, without doing anything, the screen goes black for a sec and I’m back at a login prompt.

Log back in as root, my terminal is gone - the zypper update got toasted. rpmdb is corrupted again.

Doing a reboot - but openSuse and I are NOT working out. It hates me.

^^ Doofus ^^

Yast doesn’t hate me, motherboards do. Turns out the newish PC my pc guy gave me has a bad memory slot (all 4 chips passed memory test in slot1, but when loaded up into 4 slots memtest would crash/hang/fail).

Pulled a little switcharoo and things are chugging along a helluva lot smoother now. $20 says I just jinxed myself.

Sorry, but why you start it with root login after installation? :sarcastic: See the wiki-page in my sign.

> Log in as root first thing. Open up a terminal, run zypper refresh …

exactly what do you mean when you say you “log in as root”?

are you logging into GNOME as root???

if so, that is mistake number one–never do that, ever!!

format and install again…this time install while connected to the
internet and BEFORE you begin have a look at http://tinyurl.com/6jwtg9
first, and read some of the links there (LOTS has changed since you
were last using SUSE…for a while at least you need to kinda catch
up and pretend to be new to Linux)…

AND, take a real good look at http://en.opensuse.org/INSTALL_Local
which is a step-by-step outline of installing from a DVD (DO install
from the DVD) and nowhere does it require you to log into GNOME (as
root or anything else) and immediately run zypper…

instead, on first boot (see:
<http://en.opensuse.org/INSTALL_Local#Automatic_Configuration>) it
will AUTOMATICALLY set up your configuration and lead you to set up
your online update system…which will then automatically perform
some magic, at the end of which (maybe hours of downloading, depending
on your system and net speed), and if you are very lucky, you will
have a fully updated system…

i say lucky because other places here you will find lots of folks who
say 11.1 is the worst release of SUSE ever…maybe so, maybe
not…but i can assure you of one thing: your experience from four
years ago with SuSE 9.x is near worthless because back then you were
downloading a stable product, ready to run…today you are downloading
a ALPHA/BETA for the next release of SUSE Linux Enterprise Desktop
(SLED) and/or SUSE Linux Enterprise Server (SLES) to be marketed by

there ARE bumps in this new road…don’t make’em worse by fixing
problems before they show up (like first boot, log in as root and
doing your own ‘thing’)…

good luck & of course, ymmv


Yes, I was logging in as root.

As far as never doing that … it’s not like it’s against the rules or anything, you just have to be careful.

As far as WHY I did it, that’s simple. Twice after fresh installs, I had the KDE sudo gui literally crash and die on me and my authentication would drop. Sometimes it would literally just blank the screen for a few seconds and drop me off at a KDE login prompt again.

To get around this, I simply logged in as root.

Now, the key here is that I had a bad memory slot on my mother-board that was causing all types of memory issues which were causing my problems. I swapped my machine out for an identical one that DOESN’T have a memory problem and literally ALL of my problems have gone away.

Sorry for the confusion.

No problem! Have a lot of fun with openSUSE! :slight_smile:

> As far as never doing that … it’s not like it’s against the rules or
> anything, you just have to be careful.

have it your way if you wish…but, the old heads who were running
unix-like code on big blue big iron in the 60s tell me to NEVER do
it…you can’t be careful enough…

you are miles ahead to NEVER do it…

sign into the GUI as a regular user and THEN become root in a
terminal…or use sudo…or whatever…

ymmv and do as you wish.


It’s his machine, he can do what he wants with it.

Anyway, glad the problem is solved. :slight_smile:

You’re not really getting it. I do not typically sign in with root, I understand the pitfalls. But in this particular circumstance, due to the memory issues on the machine, the kde process that would authenticate and hold my sudo token was crashing. This meant that in the middle of say, a Yast update, Yast would suddenly lose permissions to install RPMs.

This blew.

So I logged in as root and got around the problem. Only later did I realize I was having a hardware issue.

Please tell me you got it this time.

> Please tell me you got it this time.

i got it–it is NOT necessary to log into a GUI as root to run YaST,
even in the situation you describe…

try this:

at the FIRST boot up screen type 3 and hit enter, which will dump you
to a non-X environment, log in as root and type yast and hit enter…

see, NO GUI log in as root required or advised…EVER.

but, as i said earlier: do as you wish…

please tell me you got it this time.